FBX animation from blender is broken in studio

Hey, I have been trying to export an FBX animation from blender into studio for way too long without any sort of luck, the issue is that secondary bones (eg: arms/legs) will seem to be inverted(?) when imported into the default Roblox animator.

Blender animation:

Roblox animation:

Current FBX export settings (assume that any settings not shown in this screenshot are the default):

.blend file:
ClassicS15RigV2HandWeights2.blend (1.8 MB)

So far I have looked at pretty much every post on the Blender and RobloxDev forum’s which somewhat relate to the issue with zero luck and have tried basically every combination of FBX export settings in blender.

If you have absolutely any idea on what the issue is I will be extremely grateful, this problem has been killing me for months.


It’s hard to tell because I cannot see your animation timeline in the images (And I cannot open the blend file at the moment since I am on mobile), but make sure that your animation frame rate is the same in blender as it is in studio. In addition, I have seen that the start frames of an animation being different in blender and studio can cause problems. Try setting the start frame of your animation in blender to 1 instead of the default 0 to match how it is in studio. Also, maybe avoid using ik with your bones; I don’t know if Roblox fully supports it.


I already have the start frame set to 1 with the same framerate in blender and studio and am not currently using ik constraints, i believe i have figured out the issue however havent tested my idea yet

  1. Check your armature scale in blender. If it is negative, everything is flipped.
  2. Check your mesh scale in blender.
  3. Try re-importing the fbx file back into a new blender file. See if something exported incorrectly.

Those are easy mistakes to make.


re-imported the fbx and yeah i now see the issue lol, really huge thanks for telling me this


I’m now using this as my first line of defense! It’s almost always a blender issue.


managed to get the animation working on a bone rig however when importing it as an s15 rig it still has the same issue, any ideas?

1 Like

Ah, that’s probably because the S15 and S1 rigs don’t look like normal rigs. The S15 rig is readily available in the Skinned Mesh thread (aka Lola). The bones jut out to the side.

To use the Lola rig, just line it up with your model, then parent to the armature as usual.

Or, if you only need animations you create, you can import as a custom avatar and just add a humanoid/whatever you need.

1 Like

ah so your idea is to just replace my current armature with the lola one, ill check that out later

got to this however things like shirts and pants wouldnt work on my rig and if i uploaded the animation to roblox and tried to insert the animation onto a normal r15/s15 rig i would still get the same messy result

1 Like

finally figured it out! the issue was that i had to set all the bones roll to 0 and pointing exactly Z up, that took way longer to figure out than it should have. once again big thanks for helping me fix this problem


When the bones point straight up, you have the S1 rig. In the S15 lola rig, the bones point to the side, and due to some naming shenanigans, they merge with the parts. Both are backwards compatible with R15, so you are golden!

The S1 rig was never given to us. I agree it took too long to figure out. But, like the lola rig, you can just copy this over to any custom avatar. Have fun!


can you explain with screenshot?

1 Like

So I’m seeing similar issues and trying to figure out what’s going on. Here’s a pic of my modified R15 dog rig. Basically I’ve added some bones on the end of the head (really the neck) some fingers and tail bones. When I import these as R15 any exported fbx animation I do from Blender comes in slightly wonky. Is it possible to import fbx animations on a modified r15 rig and or can I get caged clothing to work with a custom rig instead? Thanks for any help. I’m going to try the bones z up to see if that works.