"File is corrupt. Please try another file" when trying to upload correct audio

Reproduction Steps
Try upload the following audio into Roblox: https://easyupload.io/v7ji8r
This audio was composed by me in FL Studio and exported using the same DAW. The file is not corrupt, as all audio players can play it without issues.

Expected Behavior
I expect the audio to be uploaded.

Actual Behavior
The website refuses to upload the audio for the reason of “File is corrupt. Please try another file.”
image

Issue Area: Roblox Website
Page URL: https://www.roblox.com/develop/groups/4965800?View=3
Impact: High
Frequency: Constantly

22 Likes

I may think that this is not just you but an issue on ROBLOX’s side.

image_2021-07-24_023900

I have attempted 3+ times to upload an audio. (Tried different audio files too, and no results than the
”File is corrupt. Please try another file.”

IF this is an issue on ROBLOX’s side, I hope they fix the problem quickly.

4 Likes

Try to play the sound file or open it on your computer, if it doesn’t play or open, it’s corrupted.

1 Like

Hi, yes I have opened it on my pc and it plays fine. Reclarifying my statement, it seems that this is an issue on ROBLOX’s end since I have asked other people (some peers) and audio uploading has not been functioning correctly at the time. I have also tried uploading via the asset uploader in ROBLOX Studio, still failing to upload. I have re-exported the audio I have attempted to upload with Ableton Live 10, and still the file will not be accepted and appear as ”File is corrupt. Please try another file.”

1 Like

Right, this does appear as an issue on ROBLOX’s end. I’d suggest trying to create another audio file. For more information, I’d like you to tell me what the audio file is trying to play. Furthermore, this is likely a mishap on ROBLOX’s end and not your end.

2 Likes

Yep, been constantly encountering this issue as well. This exact issue was listed as a bug three months ago, and was supposedly fixed. Tried uploading audio yesterday and nothing (After trying multiple files) works.

firefox_dreFQvHxYi


4 Likes

Oh gosh yes I’m not the only one with this issue. It’s important to note that it will also consume your robux even though the audio does not upload.

I haven’t been able to upload any new audio for a week :frowning: I cannot work on my game update until I can.

  • Before upload
    image
    image

  • After upload attempt
    image
    image

  • Robux has been consumed from attempt:
    image

I didn’t realise it was consuming robux, so I have used around :robux: 2,000, but that doesn’t bother me personally. But for smaller creators this is a big issue! Another user with the same issue:


I have tried:

  • Re-exporting the audio to a different hard-drive in case the hard-drive was messing up.
  • Exporting audio with another program
  • Exporting audio as .mp3 instead of ogg

But these do not relieve the issue for me.

7 Likes

Roblox automatically moderates and shortens uploaded asset names without preventing the asset from publishing on the site. Considering the amount of people reporting a similar issue – again, the forum post I linked is giving me the exact same error – I’m skeptical that it has anything to do with moderation.

For example, attempting to upload audio that’s already been uploaded to the site will still error:



Please don’t give out advice based in superstition.

3 Likes

I am still wondering if the issue is still present to this time? Have they fixed the issue yet?

1 Like

I’ve been running into this frequently as of late, too. The sounds I’ve been uploading load & play just fine in any audio playback/editing software I’ve tried them in, too, so it seems like a Roblox issue.

8 Likes

Running into this issue too since the beginning of this week. This has been a big problem for me trying to upload audios longer than 5 minutes.

4 Likes

I’m having the same exact issue as well. It’s slowing development. :confused:

I’m Having the same issue lost 300 robux

1 Like

Having the same issue, hope they fix this soon.

I can confirm that this is still indeed a problem. I’ve been trying to upload files for the past week.

I am worried about uploading audio since I am a smaller developer and my Robux isn’t incoming that great, so I don’t want to lose all my Robux. Hope they fix this soon.

After transcode to internal format of ogg/vorbis, if the file was larger than 4MB it was failed in error. This issue should now be fixed! If this issue is still occurring, please create a new topic for us to look into.

11 Likes

It’s working for me now! Thanks!

1 Like

It is now indeed fixed! Thanks!

Also, although this is not as important for me, I understand it can be very important for smaller developers without a lot of Robux. Is it possible that we could recover the Robux we lost due to this bug? The files didn’t upload before but it still took our Robux.

Agreed. We are looking into which developers were affected in order to issue refunds. Your patience is appreciated as we work through this.

2 Likes