[FIXED] Roblox fails to properly reinstall

This is something I’d put in bug reports if I could, but well I can’t.

Anyways, a week or so ago I noticed I kept getting error code 280 whenever I try to join certain games (other games were seemingly fine) so I decided to uninstall Roblox a few days after to see if that would fix it. Now when I try to reinstall it, an error window shows up with a huge amount of text I’d rather just show a picture of.


I’ve tried flushing my DNS cache because apparently that worked for some people, and even deleted the entire roblox folder in the APPDATA directory and none of that has changed anything. Any suggestions?

P.S: I should note that the Roblox app on the Windows Store does work, but who uses that?

1 Like

You can try to follow this tutorial to see if it fixes the issue for you:

DIdn’t work sadly but thanks for being the one person to try to help

Contacted roblox support about it but they didn’t help at all. Not sure what I expected to be honest

Alright I finally found out how to fix it. You need to open registry editor and go to Computer\HKEY_CURRENT_USER\SOFTWARE and then delete the roblox key and all of it’s subkeys. Then simply reinstall roblox and it should work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.