For TextLabels with TextWrapped=true, a space precedes a new line if the previous line is full

When writing paragraphs using TextWrapped=true, you will get a space as the first character of a new line in cases where the capacity of the last line was filled up perfectly to its max text length, not including the space. That is, cases where there wasn’t room for the space on the previous line. Instead of getting rid of the space character because a new line was created, the space bleeds down to the next line and it looks bad. Attempting to get rid of the space moves the last word from the previous line down. In this case “theheat” would appear on the bottom line. It would be nice if these were eliminated.

Edit: I say that in these cases, only one space should be removed. After that, if there are more spaces, they can remain. This would allow us to do indentation.

11 Likes

If you set it in a script, you can just use \n and no spaces between “the heat” (e.g …“the\nheat”) and it will insert a newline without the need of a space or joining the words.

Just as a temporary fix, of course. This shouldn’t be happening in the first place anyway.

1 Like

Bump. This bug is still a slight annoyance :frowning:

3 Likes

This is still an issue.

1 Like

sorry for bumping but this is still an issue
I tried removing the space from the Line but it also removes the first character instead of removing only the spaces (Im not wrong, I did :sub(1, 3) and it didn’t remove the space, so I did :sub(2, 3) it ended up removing the first character too)

This issue is very annoying and it’s 6 years now, still not fixed yet

1 Like

I’m having the same issue. Are there any workarounds for this?

1 Like

I added extra space for other lines

1 Like