Game-breaking problem with sound cutting out for entire game window (even core sounds)

For a while, within a game I am working on, in game seemingly randomly the sound for the entire roblox window will just stop, even the escape menu’s sound slider will not make any noise, all sounds in game will play, however no sound can be heard.

This happens in both studio play test, and occurs launching from the website. This problem is also reported by my game’s testers, I honestly have no idea what is causing this, I don’t know if it could be from a script because I don’t think a script can mute the entire engine like this.

This problem is very game breaking for me considering that all players within my game have gotten it, and the sound never comes back, and it seemingly doesn’t have a cause or, if it does, it doesn’t seem like something I would be able to fix or even cause with lua. I would really really appreciate if someone could take a look at this and help me fix this problem.

In addition, one of the triggers of the bug is when you get the ammo from the box and as soon as you get out of the menu and start shooting (clicking mouse 1) without waiting to reload, there it breaks the sound. You will have to try a few times to reproduce.

I have linked a copy of the game on google drive, and a video showcasing what I am talking about:

To test this in the game, you will want to hold L when you spawn in to skip the main menu:

You can see in the video that my FPS significantly lowers when I attempt to change the volume in the volume slider within the escape menu, it looks like it could be related to this problem:

The bug occurs at around 2:40 in this video:


This happens to me in my game as well. It only ever happened to me in Studio in rare occurrences until I enabled Volumetric audio, where it seems to be more common in Studio and even happens live in-game. Would love for this to be investigated because it’s super annoying to have to leave the game and rejoin just to have audio.

1 Like

Thank you for reporting this – we suspect it may be caused by an interaction between SoundService.VolumetricAudio and the global SoundService.AmbientReverb (which is why it also impacts core sounds).

We are investigating a fix; for the time being, you could try working around it by switching VolumetricAudio back to “Disabled” or “Automatic”, but we should have an update soon.


I have noticed a sound issue where you have to look at the source of the sound to even hear it in the slightest, so to hear your own footsteps you have to look down at your feet!

In any game with gunfire, footsteps, or voice chat, it really does not make sense for players have to directly look at the exact source of the audio to pick up sound. If you look up into the sky, you are completely deaf to all audio in the game. SoundService VolumetricAudio set to automatic, Enabled, Disabled, they’re all broken audio.

Even if the source of the audio is directly in/on the player or they’re standing right next to the source it they still can’t hear it, even if an object is in-between a player or not, why is the audio so hyper-directional??

Hey Genacy!

I was struggling with this issue in my game for about a month before I came up with a solution, this could potentially help you if this is occurring in your game.

Make sure no audios have PlayOnRemove enabled. This is the problem that caused this on my game.

( As a precaution, I also disabled AmbientReverb in my game as well )

All sound in the game appears to be ‘throttled’ by the sounds that are infinited playing and can not be stopped because PlayOnRemove provides no way to stop them.

1 Like

Hey @arccitecc, that sounds like a potentially-different issue
Sounds triggered via PlayOnRemove use a similar mechanism to SoundService:PlayLocalSound, mentioned here – PlayOnRemove & PlayLocalSound are supposed to disable looping for the detached copies, precisely so that they can’t play forever.
If that’s broken, we definitely want to fix it! Could you please file a separate bug report with reproduction steps?

@Genacy, we have a fix for this issue that will be rolling out with this week’s release; once the flag is flipped, you should be able to re-enable VolumetricSound without encountering this problem. I’ll reply again once we’ve enabled it & verified; thanks again for reporting this!

1 Like

Hello again! We’ve just enabled the flag I mentioned above – could you let me know if you still encounter this issue?


It looks like it’s gone, none of my players have reported the issue in the past week and I haven’t been able to replicate it using the ways I knew it was caused. Thank you!

1 Like