GetUserThumbnailAsync not working

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!

I want to make it where the player’s avatar shows up

  1. What is the issue? Include screenshots / videos if possible!

The player is not showing and I’m not getting any errors what so ever

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

I have looked for a bit now and haven’t found a solution. It seems everyone is writing the same code as me and there’s works for some reason.

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

local plr = game.Players.LocalPlayer
local Players = game:GetService("Players")
local plrImage = script.Parent
local userId = plr.UserId
local thumbType = Enum.ThumbnailType.HeadShot
local thumbSize = Enum.ThumbnailSize.Size100x100

local content = Players:GetUserThumbnailAsync(userId, thumbType, thumbSize)
plrImage.Image = content

Please do not ask people to write entire scripts or design entire systems for you. If you can’t answer the three questions above, you should probably pick a different category.

Just tried on my alt because I didn’t see anything that would make it not work, it works fine for me. Where is your script located? Is it a LocalScript?

very strange. I have done this multiple times before without any error and all the sudden it’s not working for some reason. Maybe it’s my roblox or something I don’t know. Also, yes it’s a local script and it’s located under the imagelabel it self.

Is this the entire script? There might be something above the following code preventing it from running.

Please refrain from creating duplicate topics, stick to your old one here please:
GetUserThumbnailAsync not working

I’d recommend adding print() statements to debug if you think there’s something’s wrong, cause it should just be a simple function to call a Player’s Thumbnail on, but you never know though

local Players = game:GetService("Players")
local Plr = Players.LocalPlayer
local PlrImage = script.Parent
local UserId = Plr.UserId

local thumbType = Enum.ThumbnailType.HeadShot
local thumbSize = Enum.ThumbnailSize.Size100x100

task.wait(5) --Maybe yield a bit?

local Content = Players:GetUserThumbnailAsync(UserId, thumbType, thumbSize)
PlrImage.Image = Content

Is the player’s avatar wearing a moderated asset?