Glowing Future Lighting Bug? Or Mesh Problem?

Hi everyone, I am experiencing this very weird lighting behaviour on Roblox Studio. (No change from before and after the mass outage earlier)

^I have 4 spotlights (60 range, brightness 2.5, shadow on, future lighting) set up pointing at the mesh part. When viewed on workspace mode in Studio, everything looks perfectly fine, but when viewed in “simulation mode”, that weird lighting behaviour is just there.

Is there anyone experiencing the same issues? Or are they any suggested help?

PS:

  • I have tried shadow map and it does not look blown.
  • I also have a timed script that changes the lighting colour on loop and turns off the lights when it is daytime.
  • The spotlight emission part is invisible.
4 Likes

Hi @TheOnlyDnf_YT

try to look at this post, How to stop reflection - #4 by Wrvel

1 Like

I think you made your part neon.

1 Like

the thing is… I have tried ;-; the material is not the problem

1 Like

nah mate, the entire object is linked to the stairs down underneath, if it’s neon, the stairs would be as well

2 Likes

Could You Try to Disabled / remove the lighting and try to put them back? Do you have any bloom effects in you’re game?
if you have it remove it ( bloom)

Check also that this function is 0 image

the bloom removal did not help, yeah disabled the lighting is just dark without anything. I have tried on both MacOS Big Sur and Windows 10 Pro. Unsure what’s the problem. the entire range is messed with maximum brightness even tho it’s 2.5

1 Like

You May also check that,
this others function inside the light is lower
image

if is high it can cause that effect

1 Like

Unsure if that’s the issue, the spotlights outside of that area have no problem at all. Hence it’s only happening in simulation mode, not workspace. Which is questionable.

1 Like

check a lighting inside your building and check that the values are low,
I don’t think there are other ways to replicate your problem

1 Like

maybe it is coming from a script?

1 Like

nah mate i have double checked, the script only change the colour, nothing else.
the changes in rainbow colour pulling from a table and then insert into color.new then apply to the lights

2 Likes

I have more or less tried to find all the ways to replicate your problem, and i think you’re problema it is related to brightness

Look at this:
https://gyazo.com/7c9624333e8e743b08293e203cb056b4


this is how it looks within the workspace

Really strange, since they are 4 lights, if you try to create new ones, delete the old ones it gives you always the same problem?


additional information if it helps(?)

no honestly everything should go, Try to create new lights re-colors and positions and let me know if you still find that problem.


this is me standing next to the light emitting part

very strange, right now I can’t think of other solutions, maybe someone who will see this post, might have other solutions.

this is how it looks after I remove the bloom for nighttime, thanks for your mate being here mate!