Gold Clockwork Headphones purchase prompt not displayed

When I navigate to the Buy Robux page I am unable to see the promotional offer for the Gold Clockwork Headphones.

No promotion listed

However, I am able to view the offer on an alternate account.

Promotion listed

This does not appear to be an issue on my end, as I have attempted to clear both browser and Roblox mobile app data on all my devices.

EDIT:
Thanks to some helpful folks around the community, here is a list of links that appear to be working if you are unable to view the promotional offer.

23 Likes

I’m also having this issue, I’m seeing it partially appear on my ‘non-premium’ account only after constant refreshing, but on my premium account, I’m seeing it nowhere at all.

Elements do indicate Premium but no idea what it means.

image

(I’d be so mad if I miss this and Ion get it for free if i miss it and can’t buy it…)

ng-if: "!layout.isPremiumUser"

those angular if statements show the different prices for premium and non-premium subscribers

edit: i’m now investigating what the criteria is for isVirtualItemUpsellEnabled, wonder what they are :thinking:

3 Likes

It does appear that this line is how it’s shown.
image
though I have no idea how you would tell that you have up-sell enabled, or how you’d be qualified.

I really hope this doesn’t make premium users miss it hopefully those will receive it if they purposefully have stopped them from getting it.

For clarification, the offer should appear regardless if you have Roblox Premium or not. I don’t have it and I was able to see the offer, and many others have Premium so they get 11K robux from the pack instead of 10K.

I do however notice that sometimes it appears, and sometimes it doesn’t after repeatedly reloading the page. Haven’t tried other accounts though

1 Like

Some folks on Twitter were reporting that they can access the payment page by going to this link (I think it’s the $100 option). It did not work for me though:
https://www.roblox.com/upgrades/paymentmethods?ap=2440&page=Robux

I eventually found this link that prompts for credit card payment for the $100 option, and this worked, so I have them now!
https://www.roblox.com/upgrades/xsollapayment?ap=2437&paymentMethod=XsollaCreditDebitCards

Hope either of these can help.

11 Likes

First one always sent me to membership page for whatever reason.

1 Like

Attempting to use this link gives me “Payment Cancelled”. nvm, did wrong zip, was fine, hate the additional verification though.

Do you have a link for purchasing it with Roblox credit? I bought a bunch of gift cards a while ago and just have it lying around

1 Like

these links should work for roblox gift cards:

$100: https://www.roblox.com/upgrades/redeem?ap=2438&pm=redeemCard&selectedUpsellProductId=0

$200: https://www.roblox.com/upgrades/redeem?ap=2440&pm=redeemCard&selectedUpsellProductId=0

if you’re using venmo, klarna, amazon pay, etc:

$100: https://www.roblox.com/upgrades/xsollapayment?ap=2438&paymentMethod=XsollaOther

$200: not available

1 Like

i created a fresh account and it showed up, but on my main it doesnt show the option for the bonus

3 Likes

I’m having the same issue, it doesn’t show on my main but it shows on other accounts.

1 Like

It is part of an IXP (A/B-like) test: https://apis.roblox.com/product-experimentation-platform/v1/projects/1/layers/Revenue.UpsellRobuxBonusItem/values?parameters=bonusItemEnabled

Whether it is intentional that some users are not part of it, i’m not sure.

1 Like

so eventually its going to be rolled out to everyone?

It ended up being displayed for me as of today

1 Like

If you wish to buy it, head over here. I myself wasn’t given permission to purchase it from the base link on the robux page, so I used the link sent before in this thread and it worked for me both times as I purchased it twice for two accounts, If there’s a set Zip Code don’t change it or you’re Purchase will Fail.

1 Like

I tried using that link to buy it but it just says “Your payment has been cancelled” even though I typed the correct information and I have enough in my balance.

If the link already has a set “Zip Code” don’t change it, when I changed it, it resulted in said purchase failing, this may be you’re issue.

I tried 3 different zip codes, the one that already was there, my old zip code, and my new zip code. None of these worked. Edit: May be an issue with my card, I tried purchasing a gift card from the official Roblox page and they were “Unable to Process Digital Gift Card Order”.

It’s not you’re card, the cashstar link is faulty, it’s been said to never refund you so I wouldn’t purchase from there, I as well have tried purchasing from there but it always failed, and that’s when i looked up and it said they never gave refunds if charged.

If it doesn’t work for you, I’d suggest checking the links on an above post:

2 Likes

is there a chance it wont work and wont give me the item?