Grab These New Physical Dragger Features!

I can find myself using this! I can’t wait!

3 Likes

Will this worked with script and animation with IK support? @JoshSedai

Hmm, good point. We’ll note this as a possible improvement.

4 Likes

We have some more great stuff coming, too :slight_smile: Thanks for your help trying them during beta and providing feedback–that helps make the product better for everyone.

3 Likes

I remember a zoom call about this, happy to see it come rather fleshed out! definitely gonna be using these!

3 Likes

That’s been an issue for a while.
It works if you launch the place through studio instead of the website though (For me atleast)

Re - 2nd degree collisions not working: Yes I believe that is a current limitation of the limited physics simulation available in edit mode. Since simulations are not running in edit mode, we invoke a special method that does not work in run/play mode. This method only does the physics simulations on the parts that are part of the selection + anything that has an explicit constraint connection to it (and what they directly touch). The stuff that’s 2 degrees away (something that interacts with a thing that interacts with the dragged parts) is not simulated. In contrast, when you hit play, everything is simulated at all times, so these interactions can happen. We’ll have to gather more feedback to see if this issue is actually hindering people’s productivity, or just a quirk of the system.

Re - the scaling issue: This is also related to the above, the means that we have to run simulations in edit mode only involve CFrame transformations (move + rotate), so scaling actually doesn’t really do any simulation (I think you can test that out by scaling a part that has a rod constraint with another part, the attachment will move, but the part at the other end of the rod will not). I’m not 100% sure how the collisions are handled in scaling since I didn’t write that code, but I know it’s not handled in the same way Select, Move, and Rotate handle it; and because we currently can’t run physics while scaling, we can’t have the collisions work like they do in play mode. The conclusion here is similar to the one from the last point, if it is something that really impacts folks’ workflow, we may look into it.

3 Likes

What I feel would really be a good option for this, would be the ability to ‘lock’ a constraint (unless you can already do that and I don’t know how) So that if you want to test a joint, without it affecting the movement of connected joints, you could simply click on the constraint and lock it, make movements to the nearby joints, then unlock it. It would be good for posing assemblies that you are going to anchor, or just testing the movement of a specific constraint in a group that might only be activated in game selectively by scripts.

2 Likes

So I think the reason is that default rigs are only attached via attachments, and not actual constraints. While the physical draggers only work with constraints.

Here’s a video where I have a rig (only attachments) and a ragdoll (attachments + constraints / joints):

I believe the rig’s attachments are treated like welds by the physics system, and can only be moved through direct transforms like with animations and such (or the geometric draggers, which ignore welds for example).

6 Likes

I agree, this would be useful especially in the context of creating poses, for now, you can temporarily anchor parts you don’t want to move:

5 Likes

Can you elaborate? Do you mean work in the animation editor? Or plugin scripts?

2 Likes

Well, animation editor either or worked with script.

So this should work with the animation editor, without issues, if there are please report them. As for scripts, if they are running in play mode, then full simulation is occuring, so the draggers don’t really have anything to do with that.

4 Likes

This is a great update!

After playing around with the draggers I found a small bug where sometimes the part you are pushing incorrectly moves forward. Notice in the video below when the red part pushes the blue part, the blue part incorrectly moves 1 stud forward:

Expected behaviour

Repro file.rbxl (20.3 KB)

Additional information:

  • I’ve only noticed this bug happening when pushing small parts. If the parts are big this bug doesn’t seem to happen.

(Sorry if this bug has already been reported above. I haven’t read all the replies to this topic)


I personally don’t mind this change and I am sure I will get used to it. However, I’m not sure if some developers may find it confusing switching between two different select modes. As just an idea, maybe there could be a studio setting or an option to enable the different select modes. This way developers can choose which one they prefer.

3 Likes

I agree, this is an awesome feature, and I’m definitely going to use it.

2 Likes

Thanks for the report, I’ll look into this

3 Likes

FYI, I think I managed to fix the issue, should be fixed in the next release, big thanks for the report!

2 Likes

Will the rigs from the rig importer be compatible with the physical dragger in the future?

3 Likes

At some point in the future, we hope so. There’s some work to do before that happens, though.

3 Likes

It doesn’t work with me, i don’t get the same results that @JoshSedai obtianed with that eegtopus

I tried this in 2 diferent models:
NOTE: The models are humanoids with all parts joined with a Motor6D

Video 1: https://streamable.com/bww3mf

Video 2: https://streamable.com/qszdkw

If this is not a bug, Is Physical intended for move humanoids (like when you use IK with animation editor)?