Grapejuice - Easily run Roblox Studio on Linux

What is Grapejuice?

It has been long since Roblox Studio was able to be run on Linux, though through recent changes in the Wine project, it is once again possible. Since it is quite a hassle to install and maintain a Roblox installation in Wine manually, I’ve decided to create a modern wrapper/management application. My goal for this wrapper was to have as a little user interaction as possible.

The project is publicly available on my GitLab profile: https://gitlab.com/brinkervii/grapejuice

The program requirements and installation requirements are listed in the README file. Feel free to post critique if anything is too complicated or too vague.

What is included?

A set of protocol and file handlers: Grapejuice will install a set of protocol and file type handlers. These allow you to open games from place files or straight from the website. After installation, Roblox Studio is directly available through your applications menu as well.

A management application: Though it shouldn’t be needed in most regular use, the management application gives you fine-grained control over the installation.

Screenshot_2019-04-05_14-25-56

Changelog

I will continue to update this post with all relevant changes

Update 1

Grapejuice as it is now, is a standalone application that is installed in a local user directory and therefore does not benefit from a system package manager. The application is now versioned and has its own updater.

Update 2

I’ve made some changes that fixes an issue that previously caused new installations of Roblox Studio to hang or crash. The maintenance tab now also has a shortcut to switch Roblox Studio’s graphics mode to OpenGL because some graphics modes may seize up the application in some circumstances.

Discord

I’ve set up a Discord server for people who would like to chat with others on how to get or keep Roblox working under Wine.

75 Likes

Nice job! By the way, have you tried using Player under WINE yet? I’m curious to know if a recent update in either Roblox or WINE has changed the situation for the better or worse.

2 Likes

So far, from all I know, it is currently stuck due to the anti-cheat. After I had done a bunch of work, I kept getting errors and getting kicked for “Unexpected Client Behavior.”

We are closer though.

This is cool. Thanks, Brinker.

I had actually managed to get Studio to work under Linux quite recently, but it wasn’t usable due to the networking not working correctly. Hopefully with this, we can be one step closer to running ROBLOX in full.

Native support would always be nicer, though.

From what I’ve gathered playing around, it seems that Roblox and Wine have some wonky interactions when it comes to raw/low level network sockets.

I’ve been toying around with the Wine source code recently and I might be able to patch out some of the issues when I have more time.

I have been researching a way to fix test server way before before you made this, but I’m not sure if this can fix:
https://github.com/roblox-linux-wrapper/roblox-linux-wrapper/issues/30#issuecomment-318925939 (last comment)

Interesting… Very interesting, I remember when I initially tried to run Studio on Linux (thru Wine) it didn’t work very well (namely a lot of crashes and the inability to open saved places by double-clicking on them) and the frustrations of maintaining a WINE installation. But with this? Heyy I might give it a go (I’m a long time Linux tinkerer…

But this might mean that running a full installation on Linux is very close (I wonder if Studio can run in ReactOS?) if only Linux was officially supported… Heck the client runs on Android which is guess what? Based on the Linux Kernel (yes)… Official Linux support is unlikely but yet so close…

2 Likes

It seems that that comment is absolutely right. I’ve made a custom build of Wine with that line commented out and test server works with it. I’ll try making a proper patch!

6 Likes

This is a very interesting project, and good news for those who use Linux. Even though I’m not among them, I’ll keep an eye on this! Impressive work!

Also out of curiosity, does the Roblox Player work with this too?

3 Likes

Is there a way you could package that build for debian based systems or will that be included in the project? Can you direct me to documentation which have parameters on your application if I’d like to automate and make scripts?

Isn’t Qt supposed to handle all that cross platform UI stuff though?

2 Likes

There are plenty of threads on the devforum discussing a native Linux port. Can we not derail this thread with that topic?

2 Likes

I am curious, do you know how well roblox would work with proton? It’s valve’s branch of wine basically, and they’re making improvements to it so games on steam work on linux, i wonder if roblox would work better on it

1 Like

This is awesome! Also, what Elttob said, does this work with the Roblox client too? If it does, I would completely swap windows to Linux. ZorinOS in exact.

1 Like

As I stated in the project README file, the game client does not work.

I have not tested with proton yet.

I want to mention though, I am planning to add a feature that lets you change the Wine version used.

Are you planning to create a program for the game client any time soon? It would be great.

1 Like

Hey! I apologize for being a bit of a noob but I’m having trouble installing this on Ubuntu. It appears to be partially related to this error since Grapejuice installs it’s own version of pip: https://github.com/pypa/pip/issues/5447

I’ve tried manually installing each package, modify requirements.txt, etc and I managed to get the Grapejuice icon to show up but it wasn’t executing so I decided to start from scratch again.

I’m not sure if there’s an easy fix for this that I’m missing but I am hoping that I can get this working. Thank you for your time and effort making this wrapper by the way :smile:

I’m positive that the anti-cheat problem could be bypassed. On the other hand, it’s morally questionable if such a bypass should be released, and for how long it would be functional until being patched.

There were indeed some problems with it installing on Ubuntu. I’ve made changes to fix this. You should be able to install the updated version.