Having an issue with my Mesh - Please help!

So, I am trying to learn how to 3D Model in Blender, I have made several things so far… However I am learning new stuff along the way. Today, I have made this Spiky Mesh.

It looks normal in Blender, It has all it’s Vertices, Edges, etc.

However, when I imported it into ROBLOX Studio, well…

Bad%20Spiky%20Missing%20Vertice

It appears I am missing a Vertice. I don’t know why, It looks completely normal in Blender. (The mesh has 98 vertices, 96 faces.)

(I imported it as a .obj file at first, and it was missing several more vertices in Studio, but when I imported it as an .fbx, It seemed to fix some of the vertices.)

Please tell me why this is happening.

Thank you! :slight_smile:

4 Likes

Check your surface normals: https://codeyarns.com/2013/10/22/how-to-display-normals-in-blender/

To flip normals: https://blender.stackexchange.com/questions/29132/how-do-i-flip-normals-on-this-model

6 Likes

This may help.

I’m not experienced with this category, apologies.

Your mesh may also be triangulated incorrectly by Roblox. If recalculating/correcting the normals doesn’t fix your issues, then try triangulating your faces before exporting:

You should also turn this setting on. This setting “hides” a face when you’re looking behind it. This help a lot in debugging normals. This is in the display panel (the panel that you toggle when you press N), under Shading:

image

5 Likes

then try triangulating your faces before exporting:

How do I do that, exactly? :thinking:

(Read the OP, you are indeed using blender)

Follow the screenshot in my previous reply. In edit mode, select all your mesh’s faces and then press CTRL+T.

3 Likes

:clap::boom:It worked!! Thanks so much! :boom::clap:

Fixed%20Bad%20Spiky%20Mesh

5 Likes