Having problems with Motor6D tool animations not playing entirely

I’ve been trying to fix an issue that started happening to me just today, that involves the “BasePart” that is welded to the player’s arm to not be animated by the local animation that is played after it’s welded.

This is an example of the issue I’m experiencing, I brought a friend to help me test it in-game because the issue does not seem to appear in studio and I’d like to say that it just started happening today.

I’ve tried Setting the network ownership of all parts of the tool being welded to the player, loading animations individually from inside the tool instead of a folder in replicated storage and none of these solutions worked and I’m starting to believe that this is more of an engine bug rather than a coding error, if it wasn’t happening earlier.

This “Animation not playing right” issue seems to automatically fix itself whenever I approach the other player, in which case the animation automatically fixes itself to be the way I intentended it to only for that player that was approached, all other animations seem to remain unloaded unless I do the same.
I really have no ideas what to do and I would have posted this in the bug reports, if I was able to make topics there.

Anyone, if you know anything, or have any solutions for this problem, I’d really love to know it!


This tutorial could help you.

(It doesn’t only work on weapons by the way.)

You see, uh, this exact post is what inspired me to work on this kind of tools in the first place. Infact I am using a system from it, except a bit more polished with my experience. This issue I stated up above did not happen at all until yesterday.

I’m not really sure but I believe the location and name of the motor6d matters. try naming and parenting the motor6d at the same place you animated the tool

1 Like

Okay! I’ll try this when I get home. Will mark this as the solution if it works.

Yep what @r0lfu said matters, the Motor6D should be exactly the same as the one used in animating, Part0, Part1, Name, and also the gotcha which is the hidden C0 and C1 properties of the Motor6D which control the initial rotation and position of the parts.

The best way to gurantee the Motor6D is the same as the one used in animation is to :Clone() the Motor6D and set it’s Part0,Part1, Parent again.

Here are some links to previous Motor6D problems I worked on for notes maybe.


I tried using this, but I don’t want to fire an event to update C0 and C1 everytime I play a new animation just so others can see it, and there are multiple animations that replace eachother.

I found a fix! The event that welded the tool to the player’s arm was fired on each equip, what I did was move the event outside of the function so it fires only once. Now the animations work surprisingly fine!

(Update: Still seems to occur from time to time, so take this “fix” with a grain of salt.)


Hello! I’ve been having the same issue ever since I updated my game and I don’t seem to understand how you’ve done it, could you please explain into more detail? I would greatly appreciate it!

For whatever reason, animations didn’t seem to play right if I fired the remote event everytime the tool is equipped. What I instead did is make the remote event fire outside of the .Equipped event (only once) and the animation seem to work fine. I have no idea how this worked, but it did.

1 Like

Thanks for the help! I’ll try it on my game and I’ll see if it works.

EDIT: I tried it, and it seemed to work, but the bug still happens if there’s a lot of players…