Having to modify "Override high DPI scaling behavior" just so Studio doesn't appear blurry and poorly scaled

Your problem is the opposite of mine. Studio applies the scaling and adjusts the gui accordingly and you want it to ignore that. Which you can do by modifying the shortcut but you’d have to do this every release.

To achieve this now, you can set your Studio shortcut as follows:

but you’ll have to do this every time they put out an update, takes 30 seconds, but still…

I… didnt even notice… wow all that space was there the whole time? And that blur wasn’t normal?

1920x1080 at 150%.

As much as I can appreciate the case for consistency here, the fact of the matter is that since this was an unannounced and undesired change in behaviour, it very much feels like an oversight.

I want the client to behave as it did previously, or an option for it to do so - changes in longstanding functionality like this are never going to be received well, and optionality should always be considered where it doesn’t add any additional development constraints.

I don’t want to change a system-wide setting for an application to function as it previously did, perfectly fine, for many years. That’s what my issue really is here - I (and many others) want a way to restore the old behaviour, and if that isn’t achievable, then the changes should be rolled back until it is achievable.

1 Like

And how can I disable the feature without ClientSettings. The scaling feature on Windows thing is not working.

I’m not talking about studio, I mean the scaling at the Client. I can’t suse High DPI scaling override, it doesn’t work.

ClientSettings used to work, but that one is gone now, and I don’t know why.

We must be talking about different things then. What are expecting to happen that doesn’t? How do you check that it isn’t working?

What I observe on my pc is that the client by default will use full native resolution of my display. I have to override that to get it to scale down. If your goal isn’t one of those things then I have no idea what you are trying to do.

Can you elaborate on what you mean by the ClientSettings not working? Does the ClientSettings folder not exist on the path, or does it just not work? The folder is still there for me.

I go to the Client folder and put in a ClientSettings like described here Having to modify "Override high DPI scaling behavior" just so Studio doesn't appear blurry and poorly scaled - #26 by ittrgrey

and then it doesn’t work, the FFlags are not working at all.

1 Like

Just a heads up, I just tested it out, the override does not work anymore for me as well.


so I have to do it for Studio to fix it for the Client?

No they are separate, this thread is just confusing both of them.

I don’t know what you’re trying to get the client to do, but my client defaults to the display native resolution. Is that not what your does? Is that not what you want it to do?

Can you explain what you are wanting to happen and how you verify that it is not happening?

I have the windows thing set to 125%

I want the application not to adapt to the 125% DPI Scale. I want it to keep the original size as if it would be set to 100%.

My client is doing that now(not scaling). How do you test that yours is not? How are you verifying this?

I know how it looked like before, that’s how I verify that it scaled it.

If I would be switching to 100% it would have no dpi scale, so that’s how I want it to be. The problem is I want to switch back to 125% for this device. Issue is that it scales it, and I am able to see that it scales it, it is bigger than 100%.

Regarding “ClientSettings”.
Whenever you start Roblox, one of the thing it does is calling this API point https://clientsettings.roblox.com/v2/settings/application/PCDesktopClient

In AppSettings.xml

when I modified it to something that did not exist, it gave me an error pointing out that it couldn’t call that address

When you run the client type Shift F2 to get this screen and verify your resolution with a number:

I have to go into my shortcut and override dpi scaling to get this lowered(scaled 125%) resolution(which I prefer). If I don’t do that I will get my native resolution of 1920x1080. (which I do not prefer)

I am not sure if we are talking about the same scaling or not, but can you check your resolution with Shift F2 and compare it with your display’s native resolution.

I have a 3840x2160 monitor set to 200% DPI scaling and Roblox always renders 3D objects at 1080p regardless of what I set the application’s DPI flags to. The UI itself renders at native resolution despite this

1 Like

How do I make the client render 3D content at native resolution? My hardware is more than powerful enough render at native and having the game render at 1/4th the correct resolution provides an unenjoyable experience. I don’t see how this would reasonably be intended behavior.


I see. That matches up with what Tifblocks was saying, yep.

Whats still confusing to me is, what was @HealthyKarl getting before that he’s not getting now?

Not sure how we’ll know if he didn’t capture any stats from when it was working as he liked it.

Also interesting the variety of what different people find enjoyable. You want 4x1080p to make yours enjoyable. I enjoy mine more at less than 1080 and tweak the dpi override so I can get 864p(if that’s a thing)
I’m sure the physical size of the screen plays heavily into this as well, i’m using a 15 or 16 inch laptop built-in display.

I more or less just want all of my applications to run at my monitor’s native resolution. 1080p does not scale well on a monitor designed to display 2160p. The visual effect is equivalent to setting a 1080p monitor to 480p. It just looks pixelated

1 Like