Having to modify "Override high DPI scaling behavior" just so Studio doesn't appear blurry and poorly scaled

For about a few years now, I have to go to the .exe of Studio and set its “Override high DPI scaling behavior” to “Application” , otherwise it would look oversized and blurry. I believe this behavior only occurs in Windows 10, as I didn’t encounter this back in Windows 7 about two years ago.

While setting the DPI override to “Application” has worked, this setting resets every time Roblox Studio updates, making it a hassle to set it every time it finishes updating. I’ve noticed that the upscaling behavior occurs mostly when opening .rbxl files that are locally saved, and almost rarely occurs when opening places on the website or places using Team Create.

OS: Windows 10 version 1709
Monitor: DELL S2240L
Graphics: NVIDIA GTX 750 Ti

Without DPI scaling override:

With DPI scaling override:

24 Likes

I have this same problem.

3 Likes

I also have this problem!

2 Likes

Bumping this, also have this problem. Roblox doesn’t scale correctly at all to high DPI displays, really really wish this would get fixed.

2 Likes

In 2018, @Tiffblocks said her hackweek project was fixing this. I’m curious if there has been any progress since.

2 Likes

This is the only problem on my particular setup. The DPI override setting works perfectly, but updates cause it to reset. This is a problem on both client and studio. Seems like fixing this would be an easy first step towards better high-DPI support.

2 Likes

Bump, more information, following guidelines of posting a bug report:

In studio, before I had a higher resolution monitor, it worked great. After getting a new monitor that is higher resolution, studio is so blurry that it begins to hurt your eyes (at least mine, anyways). There is currently no way to change the scaling of studio in the settings of roblox studio, causing us to have to resort to somewhat hacky measures.

Studio looks like this currently:

There is one way outside of roblox studio that you can accomplish this, which is to right click on the studio files, go to Compatibility, click “Change high DPI settings”, and set “Override high DPI scaling behavior. Scaling performed by: Application” to true. This works until roblox studio updates, which is practically every day (which is good), and then you have to do this process all over again.

After doing this, studio looks like this:

This fix works great… so long as you don’t have a 4k monitor. Which will cause this to happen, effectively making studio completely unusable because everything is too small:


Credit: ScriptOn

To reproduce this, just get a high resolution monitor and open roblox studio without changing any settings/properties.

System specs:
CPU: Intel® Core™ i7-9700K CPU @ 3.60GHz
GPU: NVIDIA GeForce RTX 2080 SUPER
Monitor: Dell 24 inch S2417DG monitor, 2560x1440 resolution 165Hz refresh rate

This already has existed for some time for Studio on macOS. The issue is that we’re on a fairly old version of Qt (5.6) which has a lot of bugs in its Windows high DPI support.

There’s been a lot of work towards upgrading Qt, and once it ships, it will unblock supporting high DPI on Windows.

It’s worth keeping in mind though that once we support this, Studio will continue showing the UI at its current size on high DPI systems, it will just be less blurry while doing so. If you want the UI to be smaller to unlock more screen real estate (and have good vision) then you can decrease your system DPI scale. Supporting a scale multiplier/override setting would be a separate feature.

5 Likes

What about the Roblox client? I imagine that the client doesn’t use Qt, or does it?
I keep having to override the DPI scaling for that too, every update.

Is there any current timeline for this?

2 Likes

I’ve recently upgraded my monitor to 4K and have been experiencing this issue too (wasn’t blurry with my 1080p monitor).

After seeing the discontinuation of studio for older versions of windows on November 1st of this month to support newer Qt, will this high DPI feature come anytime soon? and if it does, will it also come to client?

I’m just curious because I am planning to release a game along with a video series to go along with it, but right now the video quality is too blurry to capture any quality content.

4 Likes

Did you know this is affecting every single laptop user and phone user too?

Every 1080P laptop has the scaling resolution set to 125%, i have to set my DPI settings on a regular laptop which almost everyone has. This means roblox is actually blurry on every single laptop too!

Every phone has a custom resolution because it has to be small and fit in your pocket, so phones aren’t actually a regular screen with a 100% scaling resolution, i had noticed this on my Iphone X, its EXTREMELY blurry and i thought:
"Why is the quality of this game so bad, like can my phone even run this game and is that the reason why its so blurry?"

Its kind of insane that there is no support for a feature which would make roblox look way better for about 90% of the players on roblox.

8 Likes

This is still a problem Roblox hasn’t addressed, It’s extremely annoying having to override the application’s DPI everytime Roblox Studio gets updated.

That being said, maybe it’s time to move away from Roblox to a more competent engine which doesn’t have this problem? Considering this issue doesn’t seem to be getting tackled anytime soon; it’s already been 3 years since this report was made.

8 Likes

Is this is ever being fixed in a close future? I think that a single Yes or No would be enough to settle this…

4 Likes

Thanks to a friend i managed to get & create some code together that easily solves this issue by running a single batch file after an update, this should save a ton of time and struggle as its way faster than having to click all of the options for both studio and roblox player.

I have been changing the DPI settings now for the past 3 years about 8 times every single week for all of my devices, so i am thankful now that theres actually something that makes it easier to semi-solve this issue ourselves.

Create a textdocument, paste this code in and save it with .bat behind the name.

@ECHO OFF

set appPath="%LocalAppData%\Roblox\Versions"

cd %appPath%
for /R %%f in (*.exe) do (
    echo Found Exe: %%f
    REG ADD "HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers" /V "%%f" /T REG_SZ /D "~ GDIDPISCALING HIGHDPIAWARE" /F

)

pause
5 Likes

Instead of updating the path, you can just replace it with %LocalAppData% (capitalisation doesn’t matter, %localappdata% works aswell)

set appPath="%LocalAppData%\Roblox\Versions"
4 Likes

Unable to make a new report, but just an aside that as of the latest update, PlayerBeta at the very least no longer seems to properly respect DPI overrides

10 Likes

Just found this out, I am very frustrated but at least I know it is not just me. Great, so I play blurry now? We need a fix for 1440p monitors!

3 Likes

I am also being bothered by this. But yeah, it’s still affecting me and my friend. No solution in sight so far.

3 Likes

Same here, the scaling when I join a roblox game is oversized and makes everything look blurry. This started happening after the latest roblox update.

2 Likes

This is also happening to me, infact, now the scaling looks worse than with the setting disabled.

1 Like