Having to modify "Override high DPI scaling behavior" just so Studio doesn't appear blurry and poorly scaled

Do you have any idea how this worked before now, like when :

Previously, enabling the HIGHDPIAWARE compatibility flag for RobloxPlayerBeta would allow the client to render both the UI and 3D graphics at native resolution without scaling. As of the latest update, the client scales regardless of what the compatibility flag is set to.

Applications have the capability to apparently override that setting as well.

But since some said it worked on Windows 11, it might be an issue with Windows 10 regarding on why it doesn’t disable it.

However, Roblox used to have ClientSettings.


Please stop spreading misinformation. ClientSettings exists as a local method of overriding Roblox’s FastFlag configuration system.

This exactly; while I have a 1080p display, 864p looks awful & blurry, which is why I’ve used workarounds for years to get it to work properly. I’d much rather have a way for 3D to render at native resolution (just like every other game I play…) than a forced 864p, even if it means the UI is small. I don’t want to set my Windows scaling to 100% because it makes most things on my PC look too small, not worth it for Roblox when every other game/program (including Studio!) I use works just fine.

Studio looks just fine, I’m not sure what resolution the viewport renders at but all the studio UI is 1080p. The Client faces the issues described above.


That is true, but for some reason it’s not working anymore? Or are there any FastFlags that are working?

Another client update, time to set the shortcut dpi overrides again. Its not that bad really, haha.

I wonder why it isn’t working on Windows 10. Since probably these Fast Flags aren’t gonna come back that fast, does anyone know like third party to override the DPI scale of one specific application?

1 Like

Changing the shortcut properties works for me. Compatibility tab. ‘Change High DPI’ button. Override.

Only problem with this method for me is that I have to do it again every time they release an update.

Both the player and studio have awful scaling. I hate it. It’s an issue on both Mac and Windows, and I wish someone would fix it already.

(As a Mac user, I have noticed slightly better scaling in Studio though…)


I mean eachtime a new update was released, I had to re-copypaste the ClientSettings folder, but that wasn’t a big deal to be honest. Still an issue though, but at least I was able to turn this DPI automatic scaling off.

However, now it doesn’t work.

And the Compatibility setting doesn’t work either, for all of .exe in there.


This has been working for me every update although I shouldn’t have to…

Save the script below as RobloxScalingFix.bat and run it every time Roblox updates

@echo off
set robloxDirectory="%LocalAppData%\Roblox\Versions"
set overrideScalingKey="HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers"
set overrideScalingData="~ HIGHDPIAWARE"

cd /d %robloxDirectory%

for /r %%f in (*.exe) do (
	reg add %overrideScalingKey% /v "%%f" /t reg_sz /d %overrideScalingData% /f | echo %%f

1 Like

@ PoshKiwi Hello, is this still being worked on? Is there a new anticipated fix date?


I created and named that file accordingly on my desktop and also in the latest version folder and it did not change the scaling after running it and rejoining a game. Did I need to run it somewhere special?

Well, I think this one might actually be pretty hard to fix.
While scaling the 3d viewport properly is doable, UI might be a much bigger issue as it relies on pixels both in properties of UI elements and scripts as well.

For me at 125% scaling in Windows the Roblox Player actually looks ok. It is scaling and still looks sharp. Meanwhile studio is a blurry mess and I am forced to turn on the HIGH DPI compatibility setting like most people here.

Roblox appears to have done some updates to the dock and ribbon scaling in Studio. While my current setup doesn’t seem to have the same problems I experienced years ago, can someone confirm if they still encounter the issue? Otherwise, I might be able to mark the problem as resolved.

umm can someone explain why did they remove this feature for me I had no problems but they removed its and I can no longer access its

The issue was made WORSE. Now even studio has scaling issues. Why was this recent studio update pushed out? It’s blown up my whole game’s interface and now parts of the studio look blurry as well.

Before the issue in the video was happening online but now in studio. Now it happens in studio as well.


I noticed with the latest studio update that UI appears to be bigger when you override the high dpi settings, not sure if the rendered resolution is still blurry as of now though,
but it does appear that some windows in studio do not scale correctly yet and still look blurry.

the fix I been using of overriding DPI settings broke with the latest update :frowning: