Help my quell my perfectionist behaviors regarding this unnoticeable issue



While I was building, I noticed, when panning my camera ever so slightly, that a small line located between two of my bricks appeared. I am unable to discern whether it’s a height issue or spacing issue, but all my increments are just fine (except for ending up with 0.05s somehow, despite using 0.1 increment with SBS).

Is there any possible way to fix this, or is this just something on its own that I have no control over?

I’m putting a rooftop over it so it won’t be visible, but increments matter to me on two grounds; one that I like perfect increments when building structures like rooms and two that even a small incrementation error can result in the whole build being off (I previously had to shift every brick manually to get rid of some really small decimals that appeared for whatever reason).


Here’s a similar case of this issue, and…

The explanation of why this is happening. The errors usually occur upon size or position, usually.


With any number, really. Those errors usually appear when you’re using Move, Rotate and Scale tools or — in certain cases — dragging an object with your mouse. But that last one can also help you out aligning the part, as long as the “part” is actually just one, single part, and the Position, Orientation and Size properties are precise enough.


I thank you for providing me this solution. A lot of what I tried however ended up in failure and I’ve already built quite a lot, so I don’t want to redo it over tiny float point errors, no matter how much it bothers me. I just have to hope that it won’t interfere with the building itself because then it will become a problem.

I tried manually re-setting the properties of Position, Size and Orientation of each part, yet still ended up with float point errors that were 5+ decimal places off. Also wrote some test code to check what would happen and that didn’t work the way I expected it to.

for _,v in pairs( do
	local past = v.Position
	v.Position =, 0, 0)
	v.Position =, math.abs(past.Y), math.abs(past.Z))

Thanks for the help though.


My alternative solution is to delete the part and create a new one. This removes the problem temporarily.


Maybe you fixed everything for one part, but the other parts were misplaced?
didn’t read


@Operatik Except I have to do that for all of my parts since I already have an office area of sorts built. I don’t want to rebuild it over super small float point errors.

@Veldaren ??? Every part is having this problem.


Happens when ever the brick is beyond 20 studs, after 20 studs it will just be unaligned with the connecting brick