High Incoming Data [Not From Remotes?]

Hello, I have a game in which I don’t send many remotes to the client. On average, each client will receive 40-50 KB/s as stated by the Shift + F3 panel, with most of that being from “In Data”. However, when I use a packet profiler to watch how many packets the client is receiving, the amount of data the client receives is nowhere near the 40-50 KB/s listed by roblox’s network panel.

I’ve brainstormed as to what could be causing such a high incoming data rate, which as far as I know should only be things like changing properties of replicated instances on the server, but have come up empty handed, I was unable to think of or find anything that’d fit this criteria. This begs the question, why is my incoming data so high when there’s almost no remotes being fired? My display is correct, I’ve cross referenced it across different devices and asked other people to test it to make sure it wasn’t just on my end, and exe vs app, and yes it’s consistently much higher than it should be.


image

Does anyone have any idea as to what could be causing this? Most ideally, resources that’d be able to track incoming data in greater detail than just remotes. The only remotes being sent are compressed vectors and the occasional “data update” remotes. Here is the profiler I was using to track remotes: Packet Profiler - accurately measure remote packet bandwidth!

1 Like

Hey,

Did you ever figure this out? I’m having the exact same issue and cannot figure out a solution

Thanks

If I recall correctly, it was due to the rapid updating of attributes or properties that was being done from the server and replicated. It was in the context of distribution CFrame data and I resolved it by sending compressed remotes from the server at a slower rate and lerping on the client.

Hey there,

I figured out the problem. It was this gizmos library that was still creating new objects every frame, even though visually it was disabled.

I wish there was an easier way to debug network traffic.

Consider marking your own post as the solution, so people know it’s solved. :slight_smile: