Highlight doesn't seem to work properly in Shindo and Shindo's Test Server

Reproduction Steps

Highlight Instance doesn’t work properly in Shindo but in my other studios, it works perfectly fine.

Direct Links

System Information
Intel(R) Core™ i9-9900K CPU @ 3.60GHz…32.0 GB…NVIDIA GeForce RTX 2080 Ti

Expected Behavior

I expect the Highlight Instance to be visible. The problem has been happening since the highlight was released, Sometimes it shows on 1 object/model in the workspace leaving the rest of the highlights Invisible.

Actual Behavior

The highlight is Invisible or doesn’t appear on models.

Preview of it working in other studios:

Preview of it not working in Shindo:

Issue Area: Engine
Issue Type: Display
Impact: High
Frequency: Constantly
Date First Experienced: 2022-08-01 00:08:00 (-04:00)
A private message is associated with this bug report


Could be related to this? Highlight instances disabled, since the ‘fix’ meshes have been noticed failing to work with highlights under some conditions

I am having this same issue, and it’s extremely frustrating because I really need this feature.

It was working fine in my game, until I tried applying it to a Mesh where it just completely broke the feature for that entire studio, it wouldn’t work on models, parts or anything.

PlaceID im facing issue on is 6866266906

Really need this fixed!

Thanks for the report! There’s a fix scheduled for this issue


Hello, do you still encounter this issue?

Yes, we still encounter this problem within Shindo.

1 Like

Thanks! We’ll investigate the issue.

1 Like

In Studio It works good

In-game it’s like this, maybe I’m doing something wrong? Are highlights only visible when they are created locally?

1 Like

Today the highlight color properties inside studio didn’t match up, don’t know if this helps.




1 Like

I just stumbled upon this ticket. Did this issue get resolved?

No, today inside Roblox Studio, the test dummy isn’t highlighted.
We are using inverted meshes to replicate the highlight effects still.


Highlight still doesn’t seem to work for this sword either as well.