HingeConstraint (Physics) issue on mobile devices

Reproduction Steps
In Car Dealership Tycoon (🚗 NEW CAR! Car Dealership Tycoon - Roblox), the cars can’t drive on mobile devices. When you try to drive the car accelerates extremely slowly.
On PC device, it seems to be working as expected. The car accelerates normally.

The cars in Car Dealership Tycoon is powered by HingeConstraints, so I assume some Physics bug in that area for mobile devices. Started to get in bug reports of this just before the Roblox issues an hour ago. No updates to the game has been released that could have caused this.

Expected Behavior
The car should accelerate and go fast, just like on PC devices.

Actual Behavior
Car accelerates extremely slowly, barely moving the car on mobile devices.

Issue Area: Engine
Issue Type: Other
Impact: Critical
Frequency: Constantly
Date First Experienced: 2022-04-14 11:04:00 (+03:00)


I am also experiencing this on my experience: https://www.roblox.com/games/891852901/EASTER-HUNT-MAP-UPDATES-CARS-Greenville

Cars glitch out/fling in my experience on mobile:


We’re experiencing similar issues for our players in Emergency Response:Liberty County. Started occurring roughly a few hours ago.


Can confirm this is also happening in my game and causing vehicles with HingeConstraint doors to fling.


This bug is also present inside of Pacifico 2: Playground Town and Driving Empire.

Driving Empire's glitch video is here.

The glitch video for Pacifico 2 is too large but has the same results.

Probable relations are listed here.

An important thing to note is that both games, alongside Greenville as described above, use a script generated suspension setup present inside of A-Chassis, an open source car physics chassis. The closest setup could be found here.

This suspension setup uses a combination of Legacy Hinges, Hinge Constraints, and Spring Constraints. It could be any of those items that are causing the issue.

It’s best to use the chassis model linked above for “replication” but if anything, here is how the suspension is usually set up. Items colored differently and shrunk for illustration purposes.

Legacy hinges are yellow, Hinge Constraints are green.

Extra: Compressed

Extra: Extended (doesn't look too different from the original picture but the physics engine is running)

The blue brick is welded to the car’s body, while the adjacent black brick is “responsible” for the spring simulation with the suspension. Attachments are in both bricks to simulate a wishbone style suspension, and here is where something is (probably) going wrong.


Happening on mine aswell…
Mobile Players have been reporting this issue, thought it was exploiter at first clearly not


Thank you all for reporting, we are investigating now!


This issue looks related to improper handling of hinge constraint limits, we have reverted a flag that caused this issue. Thank you all for the help identifying the issue, please reply in this thread if you continue to see incorrect behavior.


Driving Empire and Pacifico 2 are still encountering this issue despite game server shutdowns. It’s a lot more apparent in lower-end devices compared to higher end devices (my iPhone 13 Pro Max never runs in this issue.)


Can confirm this still occurs for lower end devices in: Greenville - Roblox after a shutdown.


On Greenville, this still happens for me on a 13 Pro Max. I just updated the app earlier today when testing this issue, got another update a very short amount of time ago, and despite staying updated and trying new/old servers, I continue to have the issue.

EDIT: It seems to be working now. I only tried three times after the latest mobile update, so I guess I should’ve given it a few more tries.

I’ve tested Pacifico 2 on an iPhone SE2 with the default vehicles, and I didn’t observe any issues. What device are you testing with?

Reports came in via our communications server’s bug reports channel, although only one report went there after server shutdown (plus another one in our general chat).

The player who reported it observed another player who had a glitched car so I am unsure what device the glitched player was on. To be clear, though, the percentage of glitched cars has dropped ever since the push.

Here’s a link to the video that the reporting player took. - YouTube

Still experiencing this issue on Car Crushers 2, just tried in a fresh private server on an iPhone XS. Colliding with anything will cause the vehicle to glitch most of the time.

Video link

1 Like

Could be caused by stale flag values on the device simulating the jittering car. We will continue to monitor.


Can confirm this is still happening in new servers on Canterbury & District Bus Simulator V4.1 making it pretty much unplayable for mobile users.

EDIT: Seems to be fixed now.


I am having similar issue on mobile for my players. I tested it out on my iPhone XR. When one of my trains spawn, the train completely flings it self and goes into the void. Meanwhile, on PC it doesn’t do this. I also tested the behavior regularly without the train spawning in and as soon as I sat in the vehicle seat on mobile, the train gets flung.

Here is a video on mobile. This is the 145 St Express track spawn with the R62 train model.

Mobile Video Reference

I’m having some issues with AlignPosition, it flings only the mobile players.

This is caused by an unrelated issue, which should be resolved. Please see AlignOrientation Does Not Work - #22 by EndorsedModel

1 Like

Seemingly is occurring again today, started to recently do it around 5:57 PM CDT. (Can send multiple videos of this occurring for players.)

seemingly is fixed now as i post on it, sorry about the bump on this post