Hitting escape doesn't open up the menu

Yes. With that setting disabled, the escape menu works. It looks like pressing escape now clears the selection, which is sinking input for the escape menu.

9 Likes

It seems that another result of this new keybind is that Esc no longer closes the Find menu (Ctrl-F) in the script editor. This issue persists whether the ‘Respect Studio shortcuts…’ setting is toggled or not.

4 Likes

I was testing a custom camera with lock center enabled and it was really annoying trying to stop the test.

3 Likes

Bug still pertaining.

6 Likes

Ey, this is still happening four months later. I can’t test/develop first person games which lock the mouse anymore without resorting to ugly studio-specific hacks, breaking the window or disabling studio shortcuts.

I want to be able to use the studio shortcuts in-game too, as quick patching in Play Solo often ends up more practical and faster than if done while not running the simulation.

Is there an ETA for this bug to be fixed?

3 Likes

Just saw this - this is also happening to me.

This “glitch” has been happening to me for quite a while now, using a first person shooter system is not easy anymore with the escape button not bringing up the menu. Would love some feedback on why it was disabled or if it was unintentional.

9 Likes

A post was merged into an existing topic: Spam posts

This is also still happening to me.

3 Likes

Still having this issue :pensive: Disabling “Respect Studio shortcuts when game has focus” fixes the Esc & chat / hotkeys, but disables Studio shortcuts (e.g. Shift-F5) – probably worth noting that this only happens on the client side in Accurate Play Solo

6 Likes

Was about to create a post about this, but just realised this is a very old problem. Roblox engineers please take a look at this!

2 Likes

I’m pretty sure its already fixed, try turning on the Respect Studio Shortcuts setting off.
If it still doesn’t work file a new bug report.

Disabling that was an old trick as Gigs said, and multiple others did, it’s not officially fixed

But that’s still a hacky way to do it with negative side-effects, It would be more convenient to actually fix it.

Filling already-existing old bug reports isn’t approved sadly, you’d just be told to turn your bug report into a reply to the original bug report.

3 Likes

Are there plans to fix this any time soon? It causes a pretty big inconvenience when doing a lot of play testing. If your game is LockFirstPerson, accessing the game menu becomes impossible without disabling studio hotkeys (a huge inconvenience).

1 Like

This bug won’t be fixed. According to the standard roblox logic, this is not a bug and nobody cares that you have to disable studio shortcuts to access the game menu. This is an intended feature, however annoying that may be, and sadly, nobody cares

2 Likes

Disabling “Respect Studio shortcuts when game has focus” completely removes all key connections to studio features. You can’t use backspace to delete, Ctrl + C to copy, etc… You shouldn’t have to disable every last connection between studio and the keyboard just to be able to test properly. According to the documentation, Respect Studio shortcuts when game has focus, when set to true, Roblox Studio shortcuts will take priority over inputs being captured in the game window. So you would assume then, that when set to false, it would do the opposite (Inputs being captured in the game window will take priority over Roblox Studio shortcuts.) However, instead of the game window input “taking priority over” Roblox Studio shortcuts, it just completely disables them. With the option disabled, esc and / both function for the menu and chat already, but a shortcut such as backspace on an object should just delete it as there’s nothing else in the game window that would exist to capture that input and “take priority” over the Studio Shortcut.

As you can see above with the multiple replies and likes on this topic there are quite a bit of people who actually care about getting this solved, just because you may not personally care doesn’t mean the bug report is suddenly irrelevant and “won’t be fixed”.

2 Likes

Smells like a feature request. I would write a new topic with proper title / body (that meets format) about wanting it to not disable Studio key combinations but only sink them if the game consumes the key presses.

FWIW I don’t agree with assessment above, I think it is totally unexpected that a hotkey combination would go through to Studio tools if I explicitly turned that setting off. I want Play Solo to be an accurate simulation of in-game, I don’t want Studio tools interfering.

4 Likes

Hey everyone - wanted to circle back here because this got some attention. Is the issue still happening?

1 Like

This has been fixed for a few months now - seems like the main concern was studio not responding to esc

1 Like

It’s happening to me now, not sure why. Disabling Respect Studio shortcuts when game has focus did work though.

Also happens when you have Reduced Motion setting on in-game.

1 Like