Horizontal scroll w/ mouse wheel breaks camera zoom and instead tilts camera

I’m once again running into this issue while using a Logitech G502 wired gaming mouse on Windows 10. It only seems to be an issue if I have to press control. Very frustrating that this wasn’t looked into before being released.

6 Likes

I’m using a Corsair Ironclaw and just encountered this issue after messing around the camera settings via the in-game control menu (Esc)

5 Likes

I’ve uncovered some more into this problem. In Roblox Studio:

  • A function bound to Enum.UserInputType.MouseWheel via ContextActionService is not triggerred at all by scrolling my mouse, only by scrolling my trackpad.
  • The InputChanged event of UserInputService is only triggered by scrolling my trackpad, scrolling my mouse doesn’t trigger the event.

In comparison to this, scrolling triggers InputChanged via UserInputService in-game, but doesn’t trigger ContextActionService binding to Enum.UserInputType.MouseWheel

However, scrolling my mouse does “trigger” and zoom the camera in the following games, which suggests there’s some variation depending on the how the input is handled:

Roblox is the only software which I’m having this problem on, and the problem is limited to 90% of game’s I’ve played, and Studio. Please look into it, I didn’t buy an expensive mouse for it to only work properly on 99% of software… the 1% being solely Roblox.

13 Likes

bump – still happening even with a cheap mouse

7 Likes

bump once again because i have a razer basilisk and it’s been happening to me too since last week.

3 Likes

Bump, happens to me with a Logitech mouse, albiet rarely because I go out of my way to not do it
edit: didn’t mean this to be a reply to that specific bump but whatever

4 Likes

I have made a temporarily fix for this, incase devs want to fix the issue right away.
Place the PlayerModule in StarterPlayer and replace the BaseCamera module with this.
BaseCamera.rbxm (18.4 KB)

8 Likes

How did you implement the fix? Would be interesting to know if this has anything to do with the weird ContextActionService stuff on my end.

3 Likes

I have removed the horizontal scroll completely, now whenever you try to use the horizontal scroll, you will scroll in / out instead.

2 Likes

Does anyone know how this is triggered? is there something I need to avoid, I’m using a Razer DeathAdder Elite mouse, with no side scrolling. I just had this happen for the first time today, never had this happen before on this PC or with this mouse over several years of usage and Roblox play.

6 Likes

It is triggered by pressing CTRL

1 Like

Not doing anything at all to trigger it on my end, I never have the need to press CTRL in a game. (MacOS)

I have pressed it by accident sometimes because i had to run with shift, but sometimes you have to actually spam the CTRL button in order for it to happen.

This really needs to become a top priority to fix. This is completely breaking certain games making many players have to leave the game or be stuck with a super awkward camera angle and having to spam I and O zoom the camera in and out.

Side Note: Its being triggered by control and mouse scrolling

5 Likes

Just for clarification, once you accidentally do this to yourself in a roblox game, it’s permanently broken. This isn’t fixed by simply rejoining a game. Please anyone let me know if you’ve found some kind of short-term solution to give me my scroll wheel back.

Edit: When I posted this, I was playing on Mac and rejoining did not fix this, however it appears on Windows you can rejoin and fix it.

2 Likes

It’s fixed it for me, but that again I haven’t tested it in a while, (no need to use control.)

3 Likes

This thread was started in December of 2019 and is still an ongoing problem.

I would like to see a resolution to this because this is an annoying bug that can sometimes break entire games.

17 Likes

It’s been happening for months now, and there’s not even a viable fix. This bug makes everything extremely difficult and can literally be game breaking in some cases.

7 Likes

i figured out that the bug only happens on the new camera zooming. to understand what i mean is if you join a game like jailbreak and zoom out/in, it dont zooms out/in smoothly and if you try that scrolling bug, it doesnt happens. so maybe its because the new zooming thing has a script that the old one dont have, that breaks the camera. sorry if you dont really understand what i mean but im trying my best to explain it.

2 options that i thought of:

  • replace the zooming thing with the old one
  • try to find a fix for the camera bug and still keep the new zooming thing

i didnt just try this old/new zooming thing just on jailbreak, i also tried it on many other games that still have the old zooming.

3 Likes

I really hope this gets fixed, as said previously this ruins the player’s experience. This has been an ongoing issue for quite some time now. They said it’ll be fixed in early January however 4 months later going on to 5 the issue still exists. The only way to fix it from a player’s standpoint is by rejoining (which doesn’t work sometimes) or having to work around to using i/o or ctrl + mousewheel. Eliminating a key that a developer may use in their game

6 Likes