How can I remove this outline?

These parts with textures are creating these outlines around the map. I am looking forward to removing them. Any ideas as to how I could acheive it?

They seem misaligned. Perhaps use a different size increment

For example: image
that limits parts’ size to [ 3, 2.5, 4 ] instead of [ 3.291, 2.54, 4.902 ]

To fix it, you could:

  1. Drag each part again to make them align, perhaps with the use of these two

  2. Use a plugin, such as:

  3. Start over, but with a fixed move increment

I dont believe that is the problem. Each size axis value is an integer number and the texture’s size is 1x1 stud. They should be aligned well.

My bad. I totally misread it.

If you’d like to remove each and every Texture, you could:

  1. Do it all manually by double clicking and pressing delete.
  2. Run a quick loop in order to remove/adjust them altogether


for i, v in pairs(workspace:GetDescendants()) do
	if v:IsA("Texture") then

To execute the script, toggle the command bar and input the code

Thats not it either - I want the textures. i just dont want this weird black line around each part.

Could either play with the texture’s offset: image

Get a new Texture without ugly outlines by searching on the web, editing it using software or using a good Texture kit/pack

I just put the offset at .5 in each. Did not get satisfying results.

This is something that confuses me to some extent. I have some big parts as you can see. If I had a big part as the whole roof, it would apparently be fine. However, the divisions are between different parts. Is it still the texture’s fault? Even with the offset being half studs per tile, this still happens.

Edit: I just tried using a different texture from a random pack. The same happens.

What is your Increment Move tool set to?
If you use increments like .1 they don’t convert well to a binary (computer) system.
It’s better to use an increment like .125 which converts well to the binary number .001
You can look up ‘floating point error’ online to see the exact definition.
This increases floating point error issues the farther you get from world Position 0,0,0.

Check to see what the exact Size and Position of the Parts involved are. Also you can try deleting the Textures just to see if the Parts themselves are causing the lines.

My increment is at 0.5. AFAIK, this should convert well to binary, but Ill switch it up to 1 to test, nevertheless.

The position and sizes are all integers and are positioned well. Also, without the textures, it is rendered fine. I do, however, want to use textures and they are causing me this problem.

I’ve heard of the issue being caused by having a 1 or 2 pixel dark edge on your Texture.
Can you edit it to remove a couple pixels from that edge?

This is the same texture Roblox uses for the Slate material. I can provide you with the image, but there are no borders in the image.

I am also putting the offset at 0.5. This does not fix it, thus, border does not seem to be the problem here.

I’ve see in other posts where the person having the issue said “the texture looks fine” but when they put it into something like or another editing program and blown it up to about 1000% to look at the edges they find a dark line.

Also, did you actually click on the numbers in the Part.Position X,Y,Z values like you are going to change the value by typing it in?
Roblox will round 4.0004 to 4 and it can be visible. I’ve entered 0.xxx1 to 0.xxx9 values before to perfectly align Parts.
Also Rotation can have the same issue as well.
I know Roblox hides edges pretty well with Part Material SmoothPlastic. What is the Material of the Part with the Texture in it?

Ill take a look.

In some situations, yes. For the most part, I always duplicated the part and moved it in a 0.5 studs increment.

Smooth plastic, indeed.

This hapens normally when placing random textures on each other or just having normal part where close under it is another texture,

I tried fixing it several times in studio but I did not find way to fix it, so I prefer just using normal materials or when I use random texture I just place it only above part with basic roblox materials and not another texture.

So, is there no way to fix this without using unions?

Pretty sure this is called ‘z-fighting’. You can either use unions or change the z property of each part slightly.

Won’t this make the differences noticeable? I mostly wanted to make it seemless. Or perhaps you are refering to the ZIndex of the texture?

Works with a 0.001 difference.

Tried changing their Z by 0.001 each. Seems to not have worked?

Not sure then. Changing their increments and unions were the only solutions I could think of and would work.