How to avoid a MiniMap gets brighter?

I created a MiniMap based on this example:

I adapted it to zoom using the MouseWheel.
But I noticed that the further the Camera gets from the ViewportFrame, the brighter the MiniMap gets:
a

How to avoid this effect?

1 Like

I’m assuming that you’re achieving this zooming effect by moving the camera’s y axis up. This might be a limitation with ViewportFrames to save resources when parts are far away from the camera’s view. Can you provide some code so we can diagnose the problem a bit better?

Try Lowering Y Axis Or Mess With ViewportFrame’s Colour Settings

Yes.

RunService.RenderStepped:Connect(function()
	CameraMiniMap.CFrame = CFrame.new(HumanoidRootPart.Position + Vector3.new(0 , ZoomMiniMap, 0), HumanoidRootPart.Position)
	PlayerArrow.Rotation = -HumanoidRootPart.Orientation.Y - 90
end)

ZoomMiniMap is the Y value generated by MouseWheel.

The further the camera, the brighter the MiniMap.

Already did, no changes.


Try Changing Fog Settings In Lighting

Already did a lot of changes in lighting, but no changes.
image

Anyway, it wouldn’t be right to change something in Lighting, as it would affect the entire 3D space.