"HTTP 500: Internal Server Error" Publish Message when adding certain model to game

Hello all,

I am trying to insert certain vehicles into my game’s quality assurance plate. However, when I try to publish the game with these specific models, the publish seems to fail and throw an HTTP 500 Internal Server Error error. When I remove the vehicle(s) from the baseplate, the publish successfully goes through.

Our game is decently big, with lots of scripts and features. We have removed a lot of excess scripts, models, terrain, etc., in the past few months to hopefully never run into this issue, but it seems like it hasn’t worked. We have also reviewed the Upload Failed/Place Too Big article by ROBLOX, but it doesn’t help as we have already tried the recommendations provided.

Here is a video visualizing the issue:

There doesn’t seem to be any valuable feedback from this error message, as it does not tell me precisely the issue. I also duplicated a car later in the video that went through in a publish ten times and published again to visualize that I am not hitting an object/model/mesh limit in the game.

Does anyone have any ideas on how to resolve this issue? Are we perhaps hitting some invisible limit of object types or are being moderated for mesh names/content? ROBLOX hasn’t given any good feedback for this yet, but I am in contact with them to sort this issue out, hopefully.

Thank you in advance for any help provided. I will respond quickly to anyone willing to help. Much appreciated.


I don’t think there’s anything you can do about this. You just have to wait. An internal server error means the problem is Roblox’s fault — the server successfully received the request but because of a problem with the server itself, it is unable to complete it. You can usually fix this by waiting a day or so for Roblox to sort out their internal problems.

It doesn’t have anything to do with a size limit, except for the fact that larger files are more likely to trigger the error simply because they take more time to process.

Previously, this was a documented problem with TeamCreate. They said they fixed it but if you’re using it, try turning it off and publishing it.

You can also try using a VPN when publishing.


I’ll try the Team Create solution in the mean time. Hopefully, my support ticket with ROBLOX or this thread will allow ROBLOX to acknowledge and fix this issue. I’ll let you know how it goes. Thank you


is this error only producing for you? Have you asked other members with access to try publishing?


Yes. @SEEME234K has studio access and the same issue occurs for him.


As soon as we add the vehicle in via file or by copy + paste methods the output sends out the “Connection Error: 500” and we have to shutdown studio and relaunch otherwise roblox will never autosave / save / publish the game plate, manual saves also don’t work unless we manually download the plate.

(Downloading a save, adding the vehicle and publish / saving to the active plate also fails)


Yeah, then this is entirely Roblox. Nothing any of us can do sadly :frowning:

1 Like

I have turned off Team Create, and the publish still fails.


I’ll also add that I posted this in Help and Feedback and not Bug Reports because I am only a Member and not a Regular, so I can not post Bug Reports.

Hi. Thanks for reporting. Can you provide us the placeId that is having issue? Thanks! Also, if the specific car models are having issue, have you tried to copy those models into a baseplate and see if upload fails there as well? If they are uploaded, can you link me to those models? Thanks!

Sure, here is the place id: 11927331652

Also, I have tried doing that and it ended up working. I have a vehicle base plate where I publish and work on the cars.

Just looked into it. Our backend showed you are uploading a place that is too big for us to handle. You might need to look into reducing its complexity. This is not related to instance count but the size of the place. In the video, you duplicated the tesla model vs a bunch of jeep models. It could be that the jeep model is much smaller than the tesla model.

Would this possibly have to do with triangle counts on Meshes or map size when you say “too big”?

I had the same issue in my game with 9k parts and a lot of textures. The issue stopped after I deleted a model from the workspace. Kinda odd that one model was causing the issue. It was a low poly model as well.

It is related to the size of the place file. You can view this number if you download a copy of the place and view its file size in your computer. Trying to optimize for that number will help you resolve the issue here.

What do you recommend to reduce the file size?

Hi. we have resolved a place size issue this way before LINK does it help?

Yes. I found today that vehicles take up 42% of the place’s file size. I will be inserting them instead using InsertService via scripts on runtime instead. I will let you know how this goes!

It does, yes! Instead of having the vehicle models within the studio, I just used InsertService to insert them on runtime, and everything works fine. Thank you for your help! Hopefully in the future ROBLOX servers will be able to handle such big files since games nowadays are getting crazy realistic!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.