HttpService can't be enabled (Game Setting is Broken)

#1

I need to work on HttpService but it isn’t enabled by default.
To enable it, we must use Game Settings in Roblox Studio, but for some reason, it doesn’t work for me…
When I click on the icon for Game Settings, it does nothing… It’s like when you make a broken plugin’s button…
And using the Game Setting of Roblox’s WebSite doesn’t help at all…

Can you help me to resolve that?

#2

You must publish the game to use HttpsService and configure those game settings.

If that doesnt work, reopen the game in studio.

#3

If the game is published?
In my case, it is.

#4

Is the game owned by you? Is it a TeamCreate?

#5

Try reopening the game through Roblox’s site. Make sure the game is owned by you.

Most Likely: Enable Studio API access from the configure game page

#6

Try running game:GetService("HttpService").HttpEnabled = true in the command bar if you haven’t already.

1 Like
#7

File a bug report if you can reproduce the issue then.

None of the options on the website configuration page have anything related to HttpService. You must set this in-game via the Game Settings window or the code provided above.

#8

I already enabled studio API access

#9

I don’t know what to say… :slightly_smiling_face:

#10

It worked! Thanks! I didn’t know that we can do like that!
I think it will work for everyone so…
Thanks for supporting-me!

1 Like