I can't disable gears once I enabled them one time

Hello, thanks for reading this thread.

Three or four weeks ago I added gear to my game’s Passes & Gear tab and removed it like one day later. Now unlike other places, players can join my game with whatever gear they want and some of the gears kill other players.


I can’t see a disable gears button either. I tried to fix it via scripts but it didn’t help too :frowning:



Try to look in "Configure Place Settings, and under Permissions are Gear Permissions.

Yes, I was using this settings.

1 Like

Maybe this page will help you:


It didn’t help, I do not know the product id’s. Thanks for the interest you showed btw.

Can you do into go into the Gear Types menu, select them all on and save. Wait 5 - 10 minutes then unselect them all and save.

1 Like

I haven’t tried it before will try and send the results here, thanks!

1 Like

It seems like its not fixed :frowning:

I have not been able to enable gears on any of my places in years.

1 Like

I have this glitch, how do I fix it?

1 Like

yeah roblox is weird, i’d just recommend making a new game and overwriting it with the existing one

1 Like

I’m having this same bug too, does anyone have any fixes?