I just accidentally exported an animation over one I wanted

By mistake in the animation editor I clicked “export” instead of “import” and wiped out an animation i had created previously. Any thoughts on how I can restore the original?


I’m not an animator, but since you exported it, can’t you import it back?

1 Like

cant you go to animations in your create tab of the website and then configure and then set an previus version back?

I don’t believe assets have previous versions like places. I assume Roblox has backups anyway, but I doubt they’d put in the effort to get something like that for you.

well theres no way to restore the animation. so i am afraid you have to redo the animation :confused:

An overwrite confirmation dialog is a good idea (maybe they already have it, I don’t remember)

iirc assets have revert version.

Update: Assets do, with the exception of animations. :frowning:, just not displayed on website (read post below)

Here’s my response from an old post:


Thanks for pointing this out, @Corecii
Can you take another look at the content url you’re using in the command? I’ve tried that and many variations of it, but I’m getting 404s each time. The only one that works so far is


but I can’t append a version to that,or that is to say nothing I’ve tried has worked

I’m having no issues with it.

Make sure you’re using the Id field, not AssetId.


Note: I have tried this on animations uploaded in the last week, but those are not my personal animations so I don’t feel comfortable sharing their details in public. This does work on new/recent animations.

Make sure that your command looks like this:

local id = 1594645962 for i, v in next, game:GetObjects("http://www.roblox.com/asset/?versionid="..id) do v.Parent = workspace:FindFirstChild("AnimSaves",true) or game.ServerStorage end

and use it here:

Make sure that you’re logged into the same account in Studio as you are on the website. Make sure that you have access to the animation (it’s yours or it’s a group you’re in with place edit access).

If you have any issues feel free to post the api.roblox.com response text here and I can modify the command for you to test


This is the part I was confused about. Thanks a lot. I appreciate the help.