Import custom avatar causes weird collision

Hey there, I’m in need of some help. Apologies if this is in the wrong section, but I figured it would best fit here out of all of them!

What I’m trying to do:
I’m trying to import a custom character with custom rigging to use as the starter character. I plan on using custom animations I have that work for the rigging of my custom avatar, but I intend to do that once I can import the character correctly.

How I’m doing it:
I’m importing the FBX using the “Avatar Importer” plugin with the “Custom” setting with the textures baked into the model, renaming the “RootPart” to “HumanoidRootPart” as well as adding a humanoid to the group.

What I have to do for it to move correct:
When I export the character with the origin at the characters feet, it creates the rootpart at the feet of the character, obviously. The character is floating but moves around just fine.

When I try and do it how I think I’m supposed to do it:
Whenever I export the character with the origin around the body of the character so the rootpart is in the correct location, it is no longer floating, but it moves as if there is constant collision with the avatar. I even disabled collision on every part of the character, as well as the humanoidrootpart and it still does the collision thing.

I’m unsure of how to fix this and I’ve been messing around with it for a few days. I’m not even sure I’m importing this the correct way… I looked everywhere and couldn’t find something similar to the issue I’m having, but maybe I’m looking in the wrong places. Any help would be appreciated!

TLDR; Whenever I import a custom avatar with the HumanoidRootPart at the center of the body, it makes the avatar move as if there’s a constant collision occurring between the character and an outside force. When I import the avatar with the rootpart at the feet, it works fine, but floats.

1 Like

I am not entirely certain, but I believe this is caused by the Humanoid’s HipHeight being set to zero, essentially the HipHeight lets the character controller know how low down your feet are, and so how high off the ground your character has to be, but if it’s set to zero, your character will just fall until it collides with the ground. In this case, since the legs of the character are collideable, the character does not fall at all, which is another possible problem, in the default avatar, everything except for the head and torso are non-collideable to prevent collision with the ground or nearby walls.

So my solution would be to make the legs non-collideable and configure the Humanoid’s HipHeight so that the character doesn’t just sink into the floor. Hope this helps!


Man, I was looking for something like that and I guess I overlooked it. Messing with the hip height worked. Appreciate your quick response!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.