Import preview, and blender, colors can no longer be produced inside workspace

I am still learning both roblox and blender so am taking baby steps to evaluate the effects.

I noticed new faces weren’t smoothed. I went back to blender, in edit mode I clicked “mesh”->“shading”->“smooth faces”. The first smoothing went ok, I only smoothed the parts I noticed needed it. Then I recalled all the extra faces I created and deleted, so selected all a and applied again. This is when I first lost the correct color.

The view in blender, and in the preview import of roblox, both used the correct color. It is only when the mesh is in the workspace that it becomes green.


You can see the evolution, just about. I started in the right hand side and mirroring caused the existing smoothing to break. Moving onto the far left one I smoothed the top cuff only and it was looking good, but I still needed to mirror it which as I know, breaks all smoothing.

I tried several variants to get the red color back as you can see in the middle stack. I tried deleting the material and creating a new one, which had no effect.

This is what even the green meshes look like from roblox importer:


I know I can add a single brick color in code, but I might want to use real textures someday. As the black and white in the background shows, I was going to stick with obj until I started to have transparency issues.

With that said, I have one more clue. I reverted to my saved .blend file, with the sharp faces at the top still. I have not smoothed at all. Now even that is coming out green.

Each model in my first screen has a uniquely versioned name. I re-imported those that rendered red, and now they do not. The texture palette has not changed.

What do I want? Consistency.


I reloaded roblox studio and almost all the parts that were red are now khaki green.

The red’s texture id is 11809392999.

The two on the right that were red and are now green, use 11825684564 and 11825685604.

The one on the left that was red and is now green uses 11825722354.

The lowest one in the middle that begins the tower and was always green uses 11825729762.

I think a new assetid is created for each model/mesh imported. I can apply the one that is still red and color all the others. I checked all my textures at Creator Dashboard ( The one that worked was far too complicated. Instead, I created a new 1x1 single color texture, and it took!

What a faffle though. Roblox knows all these images come from the same file on my computer and insists on giving them new ids, with all the overheads that entails. I don’t know how long the solution will last, seeing as how my previously colored assets had reverted to being green.

1x1 gives me one less variable to worry about. I don’t know where that Khaki green is from, possibly the origin of the texture map. I thought scaling texture maps to 0 (a dot) could be at fault, but that’s exactly what I did with my 1x1 texture, and it works.

I was cleaning up my assets today and I noticed I’d deleted glovered1x1.png. Seeing as how no body replied, and I knew very little about modelling for roblox when I asked, I’m 90% sure this issue was caused by using 1x1 pixel texture palette.

Obviously we can use FBX and texture maps in Roblox, we just need to beware a couple pitfalls. 1 pixel per colour is going to be sampled against neighbouring pixels. This is known as aliasing and interpolation.

I diagnosed it yesteday here: Moderation delay, too much data, servers down, or other? - #5 by barkifo

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.