Importing mesh in Studio indicates mesh has too many triangles when it doesn't . Need help!

Hey there ! Not sure if this is in the right category , but I really need help with importing 2 pieces of a tree I have made .When I try and import the trunk of the tree, it says it has 24335 triangles which is ridiculous because it has way less than that .


Here is the tree I want to import in 2 pieces [Trunk and leaves] :


Even just by looking at it , it certainly does not have 24335 triangles .

The even weirder part is , that when I try and import the leaves , the EXACT same error pops up with the EXACT same number [24335] , is this some kind of ROBLOX Studio bug ?? What do I do ? Please help if you can , thank you for your time !


Hello so it does not mean triangles like you would think. Here is a post on the dev forums that may help you with the problem. 3D Modeling Triangles

1 Like

I imported models before I know what I’m saying . I didn’t even use a subdivision surface modifier for this tree , I really am not sure from where and how both the trunk and the leaves have the same ridiculous amount of 24335 triangles . I really think it’s a bug . But thanks for trying to help !

Well first of all, you can see how many triangles are in the mesh, a cube can have 100k triangles if you want its not about what you see.

In the most recent update they changed the triangle count spot, so follow this:



The statistics are based on all you can see in the viewport or all is enabled.
For being specific select a mesh and Shift + H

Now, if this doesn’t fix it, probably you exporting it the wrong way.

  1. Select the mesh

  2. File, Export, Fbx (I just use Fbx I just find it better) but sometimes there a bugs in fbx that doesnt happen in Obj)

And now in this panel make sure you ticked “Selected Objects” and “Mesh”

If the panel doesn’t appear press N

Maybe you exporting everything in the scene, so that’s why its the same 24335 triangles, so make sure you tick selected objects