Improved collision detection for MeshParts

As a Roblox developer, it is too difficult to work with meshes that contain concave geometry.

Although the inconsistencies with MeshPart collision is negligible when MeshParts are smaller in size, the collision inaccuracies worsen as they are scaled to larger sizes; making it especially difficult when creating large-scale maps with MeshPart components.

In all cases (even outside of the examples below), the character (or any object being acted upon by physics) will literally float over geometry that shouldn’t exist.
This issue doesn’t only extend to character physics, but Raycasts as well.

If this issue is addressed, it would make working with & implementing large MeshParts easier and thus gameplay would be experienced as-intended.


What CollisionFidelity is your mesh set to? Try Precise if you haven’t already.

FYI you can enable collision decomposition visualization in Studio Settings > Studio > Visualization > Show Decomposition Geometry. There are plugins like this one that simplify toggling this visualization on/off.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.