Inconsistency in "FindPart..." methods of Workspace

tl;dr As a Roblox developer, it is currently too hard to use FindPartsInRegion3WithWhiteList and FindPartOnRayWithWhitelist because of their different capitalization of the word Whitelist.

This is practically a nitpick, so I don’t think it’s very deserving of being called a bug, in comparison to more serious bugs.

There are 2 methods in Workspace with the purpose of finding a part in contact with a ray on a whitelist, and finding a part inside a region3 on a whitelist.

My issue isn’t with the functionality, but rather with the naming.

Workspace:FIndPartsInRegion3WithWhiteList has a capital L as it’s 4th to last character in it’s name.
In contrast, Workspace:FindPartOnRayWithWhitelist has a lowercase l as it’s 4th to last character in it’s name.

This is fairly similar to this old thread as the goal is standardization. The issue here is that I have to check my capitalization, or studio will tell me no such method exists, which will just confuse me for ~20m until I notice the uppercase L on the devHub:


Now that you’ve mentioned this I can’t unsee. Why is this even a thing?


You’re right that it isn’t a bug. However, you can make a feature request to deprecate one of them, replacing the deprecated one to be named more consistently.

1 Like

Category changed.

I think it would be good to add a description on what you’re asking for here at the start of the post. It’s pretty clear to most of us (I hope), but an engineer quickly looking it over may not consider changing it. I could be wrong, but it seems right to make it more clear since it’s a feature request now.

“Whitelist” can be one word and “ignore list” is always two words, so probably pascal case gone wrong?
Weirder yet, it’s whitelist+ignoreList instead of whitelist+blacklist or ignoreList+includeList.

Regardless, problems with the FindPartOnRay family run deeper than names. Improving and/or replacing this API is on our radar.