Introducing SmoothingAngle property for PartOperation (Enabled Globally)

I’ve been waiting for this feature to come out for a while now.

I’m going to start using it right away.

1 Like

I love this update, really makes modeling more intuitive! I would be using unions, but I’ll wait until CSG failures happen less often :wink:

Can’t risk the chances of unions getting corrupted, which happens to me like 1-2 times every 2 years, so, for now, I’ll just convert then into meshes


Have the holy lords heard our prayers?, is this a miracle?!


Am I the only one that it’s not working for yet it’s been enabled in beta features?

Without smoothing

With Smoothing


I fixed it (You can not use it in previously existing games) (Well that’s for me anyway)


Try setting it to a higher setting, ie 100. I’m not sure its working fully as its still a beta thing, but it seems to be working on most unions at my end


I’ve been looking forwards to this since seeing it in the release notes and API diffs. Having the ability to set the angle is definitely appreciated, this is a great addition. I’ve resorted to using CSGv1 for smooth unions but the errors have not been forgiving. This change is all that’d be needed for me to fully switch.

However, I’ve attempted to use it on my previously made CSGv2 unions with only partial success. Some normals were smoothed, but the majority were not. I’ve also attempted to use it on the “faceted cylinder” from OP (made from 2 blocks and 4 wedges), but had no luck when attempting to set the smoothing angle until it went beyond 90 which distorted it quite badly.

I’m sure this will be great once it’s fully released, and as the beta develops, but for now it just doesn’t quite perform as I’d expect.

1 Like

This is an operation you can already do in Blender called edge splitting.

1 Like

That is a nice plane, gotta say! This will definitely be helpful for my future projects.

1 Like

Interesting, but the shadows could certainly use more polish. Using full 180 degrees on incredibly blocky and low-poly unions and csg parts makes it feel like it’s from an old game.


FINALLY! Thank you so much for adding this. This is really going to improve my builds!


This will be perfect for creating the exact unions I need.


Thank you so much for adding this, this is already improving developer’s designs already!

1 Like

Wonderful! Now my cars won’t look too weird. Amazing update, thanks


It feels like every time I set smoothing under 90 it looks the same as 0. But when I use 90 or greater then 90 it looks like 180. Sorry I did a job explaining this.

1 Like

How do you use this? I have just recently found out about CSG

I was thinking of Blender’s shade smooth.


You have to enable the beta feature in File -> Beta Features, then restart studio and you should see a new property that you can change.


When I have a union and add an angle, nothing occurs.

  1. Make sure the beta feature is enabled (if you see the property or not)
  2. Try setting it to a larger angle.
1 Like

Its enabled, and I set it all the way up to 180-- no changes.