Is it Possible to Change the Way Rich Text is "Activated"?


(Before I start I just want to add that I don’t know if this should go in Scripting Support or in Art Design Support, so I’m putting it here)

So I’ve been trying to use the custom dialog plugin by Davidii from 2017 (link to the DevForum page here), as well as the Rich Text feature.

The problem I’ve been having is that the plugin automatically detects “<” and “>” and uses those characters for it’s own “dynamic text functions,” making it impossible to use Rich Text without getting a mess of errors and the text being messed up.


I’ve tried editing the scripts for the plugin that appears in the Explorer, but every time I use the plugin again, it reverts my changes. I’ve also tried using the plugin debugger beta feature but I have no idea how to use it. Without any options left that come to mind, I’ve resorted to trying to see if it’s at all possible to change what identifiers Rich Text uses, so instead of using “<” and “>” is uses something like “{” and “}” so it doesn’t interfere with the plugin.

Sadly, though, I haven’t found a way to change the identifiers. Is there some sort of cheaty way I can do this or will I just have to compromise and not use Rich Text in combination with this plugin?

I’m pretty sure it goes in #help-and-feedback:scripting-support