Is this a roblox bug or on my part?

I’m attempting to get my vehicles working to drive forward and backwards like regular.

After the update that happened on Weds the 17th around 1:30 PM EST my vehicles seemed to have not been driving forward or backwards, I’ve had it drive forward and backwards like normal twice in studio but once I get out and back in nothing happens. Everything in the Vehicle functions like usual. See the odd part is that the cars work perfectly fine no errors nothing, it’s just it won’t drive forward or back, like I’ve said I’ve gotten it to work like normal twice in studio but thats it. The Microsoft version of ROBLOX the cars work like normal even in the game with other clients which have the update and it doesn’t work.

We’ve tried to see if the W and S were still going through properly and it is, it seems that after the most recent roblox update Rotate v isn’t properly giving the wheels torque (rotate V is what I use to power the two back wheels.)
I’m not sure if its a coding problem or not,
Here’s the game:

1 Like

I had an issue with my boats, but since I was using 2 props at the BACK face of the boat and RotateV I figured that’s what caused it to break. I changed it to HingeConstraints and rescripted it and it works fine now.


I’m just trying to figure out if this is an intended update, or just a bug because I was in studio earlier and I got a car to drive for me.

This happened to me, I reinstalled studio and it worked… did you perhaps test in a real server?

1 Like

Yeah, the Microsoft version works fine in game. But on the website version of ROBLOX the vehicles won’t drive forward or backwards, it’s only driven for me once.

I just find this very confusing considering the fact that it was working fine before the update, and everything still works fine no errors nothing, just most of the time the car won’t go forward or back. I’ve only gotten the car to drive forward twice.

Maybe it’s something simple like the Torque in the VehicleSeat needs to be increased.
Not enough torque wouldn’t give an error, it just wouldn’t move.

I realized that for me it was because I’d used Motor Surfaces and the HingeConstraints were more robust and the better update.

Well it wouldn’t be that, because I’ve gotten the car to move and work perfectly fine, and users who play from the Microsoft version can still drive as if nothings changed.

But in Studio, since the updates…

What do you mean? (30 characters)

Maybe the issue is only showing up in Studio since the updates.
If it works in game it isn’t a game bug, and just because it isn’t giving an error in Studio doesn’t mean it is working properly.
You keep saying “because I’ve gotten the car to move and work perfectly fine”, but you also say “it seems that after the most recent roblox update Rotate v isn’t properly giving the wheels torque” and “I’m not sure if its a coding problem or not”
Did you change any coding? I changed nothing in my game and most of the boats quit working, so it isn’t a coding issue.
It’s something to do with the update and we can adapt to it.

No I haven’t touched anything I filed a bug report, I hope something gets through because its a major strike for my game.

image When I press W or S there’s still throttle going through.

Yes, everything is working properly EXCEPT the RotateV motor as I said before.
Tried playing your game, but couldn’t find any cars and gave up.

Gotta go to the things on the ground and press R, it should be glowing red.

The vehicles have also been rolling alot more than usual.

Coasting after you stop pressing W or S?
Likely a torque related issue since the lack of torque when there is no input acts like that.
Have you tried increasing the Torque value in the Vehicleseat to see if that fixes it?

I’ve never had to have torque set in the driver seat, it’s always been based of scripts. Also just recently today someone got a vehicle working In game and not in studio.

If you want to change the way something works you have to try things, not just rely on “it used to work”.
That’s what troubleshooting is, trying something until you get a different output, if it’s the output you were looking for then great. If not, then back up a step and try something else.

Telling Roblox they have an issue or bug is fine, but if you can do the work to find out what the exact issue in your situation is and the factors that affect it, then that will help them out immensely.

1 Like

Yeah I know, I’ve been trying. There’s nothing that me or my team has found out over the past day, we’ve just come to realize somethings obviously not working properly with rotate V which you already know.