Issue with Lighting

Hey! I’m having an issue with the lighting in my game. The natural lighting isn’t sufficient, so I have added invisible parts with lights inside it. However, when it crosses over with a part or player, it gives them a black line. See the video for proof. I’m unsure of how to resolve this.


The properties of the part are here:


1 Like

Can we see the properties of the lighting?

If you want some great realistic lighting, I highly suggest changing the Lighting Technology to Future. Future gives the shadow and light a sharper detail and makes it more realistic. For the light I suggest enabling shadows.


In the PointLight/SurfaceLight you are using, tick the property Shadows to false.

Sure, here you go:

Already tried that, but thanks for the comment.

Hey! I already had the lighting on Future but when I changed it to shadowmap, the black line dissapeared. Do you know if Future is still in beta?

1 Like

Future still pretty new, glitches are likely gonna happen even if it’s not really beta. If there are any glitches you can report it to Engine bugs and they’ll fix it right away.

1 Like

Try using a PointLight instead of a surface light, but if you want to use a SurfaceLight set the property Angle to 180.

1 Like

How high are the lights (parts) set? Could you share a video with the transparency of the parts set to 0.5? This might be because the character goes through the light source.

Didn’t work, but thanks for the reply.

What do you mean how high are they set? Also, here is the video of the part containing the lights at 0.5 transparency: link

Try placing the lights higher so that the player’s character can’t go over the (center of the) lightpart.

Yeah, that is 1 option. I could also just make it brighter facing down. Thanks for the support. :slight_smile:

1 Like