Jump Flinging Characters

Game: War Tycoon

About 2 hours ago we received tons of bug reports with jumping causing players to move super quickly and sometimes flinging them off the map.
This is happening on all devices.

We do use Adaptive Physics, not sure if that matters.

We also did not update our game during the time when we received reports so I am going to assume it is some kind of issue with Roblox?

Here are several clips of it happening:


Sorry for the disruption in your game! There was a major update on adaptive stepping at the time and we currently rolled back the flag. Can you let me know if your experience is working as intended now?


Still experiencing in studio when playtesting the game, but just hopped into a non-studio server and it wasn’t happening

Thanks for your reply. Can you try updating your studio version and try playtesting again? Just trying to confirm that this is due to a bad flag dependency from our side.

Also experiencing the issue here! I just updated my studio to the latest version and retried test playing it again after reading your post, but the issue persists…

Can confirm this is still happening in Studio even if I try re-installing Roblox Studio.

Apologies for the subpar experience :weary: We just made some changes to our flag settings; can you restart studio and see if the problem is persisting? If so I’ll have to rollback to a stable state.


I’m glad this wasn’t an singular issue on my own place file (what was strange was it would work (not bug out) in a new place at the time of error testing)

The issue is now not occurring, at least in my files and places.

Thats awesome to hear. Thanks for bringing this up to our attention.

This isn’t fixed.

If I switch Adaptive to Fixed it fixes the issue, but I don’t want to use any outdated properties.

What can I do to fix this??

And no, before anyone comments, this has nothing to do with my scripts. I disabled all scripts that modify character movement, and while they slightly help with the issue, the issue still occurs as long as I move, or jump.

This is obviously an issue if switching Adaptive to Fixed solves it permanently.

@Hajimalago I forgot to ping reply you, please read the above

Hey! Sorry for my late reply. Can I ask if updating studio to the latest version mitigates the issue? If not, would be super interested in getting a stripped down version of your place to see what is going on.

1 Like

Also, is this happening in your live game?

1 Like

Studio didn’t have any available updates, and I did restart it multiple times last night to try to see if it had an update of any kind. It didn’t, and the issue persisted.

However, today upon checking the experience in studio the problem seems to have been solved even when set to Adaptive.

I wonder if I somehow got a Flag enabled accidentally while you guys were tinkering around with stuff on your end. I was in studio at the same time it occurred, and I never left the session.

It seems the issue was able to occur even while I was in the build. I just hadn’t play tested for 2 hours as I was programming a hefty script (nothing related to character movement though!)

I did also test my live game, and the issue wasn’t present. Roblox Player had an update last night, while studio didn’t so I wonder if that’s why it didn’t occur with the Roblox Player, and it did with Studio.

tl;dr, it seems the issue has resolved itself.

Hey @Hajimalago, our game has recently picked up a ton of reports of character flinging randomly. The first report was May 24th, our most recent publish to our game was May 20th. This is pretty serious in our case, the flinging is really frequent for some players & we are getting a significant amount of reports.
Changing PhysicsSteppingMethod to Fixed does fix the issue so we’ll rely on that for now.

Some examples of these reports from our community;


Hey Sinne, thanks for the report, and sorry for the disruption. I’ll be looking into this issue right away. Seems like this is happening in your live games, correct?

1 Like

Yes that’s correct, live game and studio both.

Also getting reports in our games of players getting suddenly flung by certain abilities where there were no issues before a few days ago.

Seems to be abilities where welds are created between characters or characters are anchored & unanchored.

PhysicsSteppingMethod is set to Default, which I believe defaults to Fixed currently? Seems like some of the physics changes made this update are still causing issues.

Think again:

Does changing it to Fixed fix the issue?

Ah! The wiki said it was still Adaptive on the Enum page… :frowning:

Not sure if changing it to Fixed has any effect yet, will have to monitor things.