Known issue for Macbooks running macOS 10.12 (Sierra) and higher

Yay, I can actually have SRGB settings enabled again; yet there is still the test server initial run issue on macOS, which I guess I will make a thread about soon if no one has been notified of it yet.

Do you press Test and just nothing happens? Like it opens a new window, wait, then it just shuts again? I haven’t tested the patch yet, I’ll edit when I do.

Also, @Silent137 THANK YOU SO MUCH!!!

Yes, instead it opens and does not connect to the test server, and I have to go into the activity monitor and manually quit it in order for it to run properly. Also, if I don’t quit the failed to open test window then all other test windows thereafter will cease to work.

This is especially annoying since I am constantly testing a multi-player game.

p.s. Does this issue occur randomly and frequently for you as it does for me?

We’re aware of the issue with Start Server/Player and it’s next on our list of High Sierra issues.


This is happening on macOS Sierra too though, specifically 10.12.6 on a 2017 5k iMac.

Looks like the laggy script editor is back on Mac since the last studio update. Any one else experiencing it?


Yep I’m also experiencing it

1 Like

@Silent137 looks like it’s back :disappointed:

1 Like

Yep, me as well


Having a super laggy editor again :confused:


Hello! I have been experiencing this issue for about 1 year now. It gets really annoying. I can’t even script, so please try to find a fix for this. There are 2 more other issues that are REALLY bothering me.

  1. Can’t test the game.

When testing the game, by clicking “Play”, it takes it about 10 minutes to load into the game, then when it does load, I can’t even move around.

  1. Really laggy when the game is Auto-Saving

Whenever the game is Auto-Saving, it just freezes for about 5 minutes. This is really bothering.

I really do hope ROBLOX fixes this soon, as it has been over a year of this issue happening.


It would help if you posted your specs and such. I’m not experiencing any of the issues you mentioned above. I have a 2015 MacBook Pro on the latest version of macOS Mojave; I can’t check atm, but I install updates as soon as I am aware of them.

You could also create a new topic(s) for the other issues you’re having as they have a lower chance of being seen here.

1 Like

I was having the EXACT same issue. I tried uninstalling studio from my computer and removing all of my plugins and it worked for me. I no longer have a laggy editor at all.

I am experiencing this issue on my new macbook pro. If I detach the script editor from the studio window, it doesn’t lag, but it’s really hard to script that way. Unfortunately, changing my color settings did not seem to fix it. Anyone else still having this issue?

1 Like

thank god, i thought i was the only one who was dealing with this. I’m even on a non retina.

1 Like

Yes, please can a fix be pushed to this, the slow typing still occurs

What version are you on?

I’ve been using Mojave with multiple script editors on separate screens running just fine.

I’m on a hackintosh ( macOS ) which I experience too many lags on the explorer which doesn’t show the contents folder that I want to open until open something else ( that doesnt load ) and select the folder again.

Hey developers,

if you are experiencing this issue or something similar, please write out a new bug report with as much detail to repro as you can. That way we can send the bug reports to our engineers and have it patched.

@Admin_Creators, @JuniorMikezz, @Krestiin & @Ice7

Info on how to post a bug report:

Thank you!