Large chunks of terrain not visible for a second with streaming enabled

Assume this is occurring on:

Any suggestions on steps to reproduce the problem?

2 Likes

Oops, forgot to include the link. Yeah, I was experiencing it just during normal play; the terrain under my character would disappear occasionally. However, if you go into the mines it seems to be quite a bit worse.

The mines are just caves, but this game has a mining mechanic where the terrain is removed as you mine, so perhaps there’s a component of this bug related to the terrain being updated often.

Here are the streaming settings.

If you’re trying it out in-game, here’s the entrance to the mines:

If you join the game again, I added $5k to your account so you can buy a pickaxe from the store if needed. I’m guessing you might be able to reproduce this outside of my game, but I haven’t been able to yet.

3 Likes

Still working on reproducing the problem. I logged into the game but didn’t see the $5k. I have a basic pickaxe currently and tried mining.

1 Like

Hm, that’s odd. If you use Discord, you can add me (kyle#7609) and send me a message when you have a moment so I can join you in-game and help you find the issue. I’m still seeing a lot of people talk about it, I’ll ask them what kind of devices they’re on since I’m definitely not seeing it as often as some of them.

1 Like

I was able to reproduce it once on a Windows desktop machine, but it is difficult for us to reproduce. We are trying to debug the issue. Any information you have on devices that show the problem more frequently would be helpful.

1 Like

I am also getting this bug at my game’s development place: https://www.roblox.com/games/505731357/Testing?refPageId=67c06624-bd16-4900-b291-3a80ffa633c5
I am on Windows 7, the bug never happens in studio, only while playing. Game is streaming enabled and has a large amount of terrain, though terrain is not placed or removed through scripts at all when playing. Also seems to be tied to the camera angle for me (if I have my character sit still it will stay as either empty or normal and I can go back and forth between the two by slightly moving the camera)

I also get a lot of these errors in the above game: Errors in console: BlackFrame is not a valid member of ScreenGui

Not sure if the two could be related

1 Like

Can you make your test place public or provide the rbxl file?

1 Like

I don’t want to make it public since there is a lot of unreleased content in there, but I’ve sent you a Roblox friend request which should allow you to access it

1 Like

I should have suggested the friend route. Are there any steps to reproduce with your test place, or areas where the problem happens more often?

1 Like

When you first go in you will have to go through the tutorial (skippable) and make a character - the area you drop into after this outside the walls with the market stalls around is a place I’ve had it happen pretty often -
A detail I forgot to mention though is that, for me at least, it tends to happen with terrain chunks that are in the area I first spawn in at for a given play session - to clarify what I mean: For a normal play session of my game you first see a main menu - when you press the play button you get teleported to wherever you were last and data etc. loads in. This is the spot that for me always gets glitched, so it can be pretty much anywhere but I do not see the glitch in other areas beside wherver my “starting area” is for that play session.
Since the first time you play you get the tutorial + character creation menu I imagine it would probably not happen, so try leaving and rejoining once you are some place in the world.

Also my game has the newer feature enabled related to pausing the game when chunks are loading in - StreamingPauseMode or something like that?

1 Like

Can you send a friend request to nacasagu? He is also debugging the issue.

1 Like

Ok, I’ve sent him one as well.

1 Like

Hello, I own an ant simulator and this issue has arisen on it as well, hopefully this is resolved soon.

1 Like

Thank you. I’ve been trying to reproduce the problem today without any success in either of the games. However, we are going to disable the change that we think caused the issue and see if that resolves it on your side. I’ll let you know when we toggle it (hopefully tomorrow). Once we do that it would be super helpful if you could confirm whether the issue is fixed, or if the problem persists.

BTW, very cool game, I’m enjoying exploring the world you have created!

3 Likes

OK guys, the change has just been disabled in your games. Let me know if you notice any changes or if the problem persists!

1 Like

So far so good here, I went in and out a couple times and have yet to see it (was doing it pretty much every time before)
I will let you know if I see it again, glad you like the game!

1 Like

Can you confirm whether the problem is also fixed on your side? Or are you still encountering the same issue?

I am still encountering the terrain issue.

Can you provide a link to your game so that I can check it out? Thanks!