Let me make my editor font italic again


Please allow me to make my editor font italic again. This ability seems to have been removed with the new editor updates.

I understand this seems unnecessary, but I have severe OCD which includes compulsions when writing code such as exact indentation, “perfectly” compact code, “equal” amounts of line breaks, font size, etc. It can be quite detrimental to getting work done, but I have found italicized text helps me a lot with controlling these compulsions (and it’s been much harder since I have no longer been able to use it). Considering how difficult and relentless my condition is, I will take anything I can get to help me work more effectively.

I understand it’s not a big deal, and it’s not something that affects anyone else (that I know of), and I push through without it regardless but I would really appreciate if this functionality could be restored.



It might help if you use a clear monospace font, which means that all characters are of equal size and spacing so that all indents and letters will fall exactly into place.

I use JetBrains Mono NL Regular, which means it’s the neat JetBrains font, monospaced, no ligatures, and regularly sized and weighted. You can also try the Regular Italic version instead of Regular, if that suits you more.

DevForum doesn’t let me upload font files, so here’s the source.

Download the font pack, then right click on the one you want and click Install. After restarting Studio, you’ll be able to select that font in the Studio settings menu.

Hope this helps!


It is a great font although I think I prefer Fira Code haha. The italic still doesn’t work :frowning_face:

But thank you for trying to help, appreciate it

1 Like

How can I use jetbrain mono font in my script font? I tried to do it but I can’t.

I use the Consalas font (might have misspelled it). It’s a monospace font and was recommended during my programming courses in college.