Lighting optimizations?

I am building a game in a night time setting and the lighting poses a few issues. There are a decent amount of lights in the game.

  • lighting is buggy; often flashes and blinks for no apparent reason
  • lighting refreshes too slowly; I assume because of the lights, the shadows refresh too slowly

I want to optimize the lighting to get rid of the lighting bugs, and hopefully fix the slow shadow refresh rate. What are some ways to do this, without decreasing the lighting quality too much?

1 Like

I’ve seen similar things happen with Future Lighting in the past. I think the issue here is the fact you have quite a lot of lights in the area and that’s causing some sort of overload, and Roblox is trying to compensate for that by making shadows laggy.
That’s only a hypothesis though, it could also be a bug - Future is Bright is fairly new, after all.

2 Likes

Hello nicopattylegs,

I’ve encountered this issue before, to say the least I would say it has solved itself.
The issue is from the light source if the light source part is:

  • behind a wall
  • perfectly aligned with a wall
  • OR maybe part of it is behind a wall

These cases would cause it to do that.

When I had that bug I just:

  • dragged out the light source more
  • and minimized the brick the light source was in

and it worked, it got fixed even though the light wasn’t the way I wanted.

After a while I brought it back to the place it was and the issue where
it flickers didn’t happen again.

Or PhoenixCraft99 could be right about having so many light sources.
Try reducing it and see if it helps too.
You can also try different types of light settings.

Now again I am not 100% of this solution but you could try it out hope it helps.
Good day!

2 Likes

It pains me to say this, but this is a common problem with Future Lighting. I have seen many similar posts on this bug for quite some time now, and so far I haven’t seen any definite answers.

2 Likes

Hello @nicopattylegs! It’s been a while since my last reply on your topic, but I believe I have found a solution to your problem! Today while scrolling through my feed, I came across this post by Billy_Dodo. Apparently it is the Shadow property of the lights that are glitching out. It seems that so far the only solution to this problem is to just turn the Shadows properties to false. However, MisterRedTurtle has stated that the DevRel Team has filed a ticket to their internal database concerning the bug/glitch and will be getting back to us as soon as a solution has been found. Hope this helps you with your problem, and if you have any questions, feel free to let me know!

—JayR

1 Like

It seems future lighting is still a work in progress. I do wish that I can keep the quality of the lighting by leaving the shadow property on, though. Hopefully this can be fixed in the future.

1 Like