Location data on Meshes don't seem to be working properly?

In blender, I’ve created this rock with ores. The base rock and ores are separate.

image

But when I export them seperately as FBX & import them, I select the “mesh contains location data, move to location?” but it ends up like this.

image

There’s another option that appears when you import a mesh ( the would you like to resize? ) I’ve tried with and without but the same thing happens.

Two weeks ago I imported multiple meshes with location data and it worked fine which is why I find it odd that it’s not happening now.

Before anyone asks, I cannot post this in bug reports ( if it’s an actual bug ) as I’m not a full member and I have searched for similar posts but couldn’t find any.

I have also tried reducing the size of the mesh in blender; same result though.

1 Like

Does applying transforms fix the problem? Select all objects, press CTRL+A, and then click Location:

image

3 Likes

They changed location when I imported them but they’re still not how they should be.

image

1 Like

Try this:

  1. Set your 3D Curson to center.
    blender_2018-03-12_22-01-44

  2. Then select all of your mesh in Object mode.

  3. Then set the Origin of all of those meshes to 3D cursor

I used to have this problem too when I was trying to upload them with their correct position and the solution I found helped.

1 Like

Still doesn’t work ;p this is rather annoying.

1 Like

Try doing this:

  1. Select all objects.

  2. Then CTRL + A then click Rotation + Scale.

and make sure the origin point is at the center grid for each of the mesh. The dot should look like this:

2 Likes

I used to think this was only me. It’s a nightmare for importing cars made of multiple meshes.

3 Likes

I’ve had this problem too - I can usually solve it by using an identical origin and orientation for all meshes.

i.e. when you set your transform orientation to ‘local’ the orientation and origin of each mesh should be the exact same when selecting each individually.

You can achieve this by applying both the location and rotation to the mesh, through the method that XAXA described.

Hope this can help!

1 Like

And just as a follow up, i suspect that’s what’s happened here as I can see your gem objects are rotated randomly - I expect you duplicated the gems, rotated each of them in object mode (thus offsetting their local axes), then merged them into one object. This means the orientation of the final merged object will be aligned to the axes of one of those gems (which will be different from the local axes of the rest of the assembly), and when uploaded with be aligned incorrectly.

Good luck!

1 Like

Hey, I know I’m a little late to the party, but I recently had the exact same problem. However, I have tried everything on this post and all the info from the replies and the issue is still not solved!

5 Likes

Been using Bulk Import ever since I encountered into this issue. All I do is publish my baseplate to a game(which can be made private) and use the GameExplorer to import my mesh.


Right click on the selected objects.

EDIT, as of 18 Jan 2021: Same workflow but Asset Manager has replaced Game Explorer, atleast for the beta version.

4 Likes

Thanks so much! you saved me so much time!

3 Likes