Marketplace & Avatar Editor do not load while using a VPN

Description of the Issue:

Pages like the Catalog or the Avatar page fail to load the assets and I am unable to complete purchases or equip different outfits

What I tried:

I have tried clearing my Google Chrome cache, tried resetting everything and never was able to fix the issue.

If I use a different browser like Opera it still does not work, it seems to be an issue maybe related to my account and not the website itself.

Being logged off my account seems to load the Marketplace properly.

Visual Aids:

Picture taken from Chrome:

Picture taken from Opera:

Picture taken from Firefox:

Picture taken from the In-game app (works fine):

My System:

System Information

  Time of this report: 07/07/2024, 15:21:30
         Machine name: MATTHEW
           Machine Id: {9CF22B26-928A-4278-A673-C603524AAED0}
     Operating System: Windows 11 Home 64-bit (10.0, Build 22631) (22621.ni_release.220506-1250)
             Language: English (Regional Setting: English)
  System Manufacturer: Micro-Star International Co., Ltd.
         System Model: MS-7D41
                 BIOS: 2.91 (type: UEFI)
            Processor: 13th Gen Intel(R) Core(TM) i7-13700KF (24 CPUs), ~3.4GHz
               Memory: 32768MB RAM
  Available OS Memory: 32628MB RAM
            Page File: 34791MB used, 5611MB available
          Windows Dir: C:\WINDOWS
      DirectX Version: DirectX 12
  DX Setup Parameters: Not found
     User DPI Setting: 96 DPI (100 percent)
   System DPI Setting: 96 DPI (100 percent)
      DWM DPI Scaling: Disabled
             Miracast: Available, no HDCP

This is just an acknowledgment announcement!

We’ve filed a ticket into our internal database for this issue and will start investigating, we will update you when we have further information.

Thanks for flagging!

1 Like

Sorry to hear that you are having these problems.

Are you able to still reproduce this issue? If yes, can you follow our instructions below.

  1. open up the chrome developer console and go to the network tab
  2. navigate to Catalog - Roblox
  3. filter on items in the search bar
  4. select the network call to and select the response tab
  5. take a screenshot and send it over, something like what I have here:

Hey! Thank you for the quick response
Apparently I’m sending too many requests, but I assure I did not spam refresh or anything of the sort, it’s just happening by using it normally.

For the avatar page it’s the same reason:

Though I now understand why it happens, it’s due to me using a VPN. After disabling my VPN I was able to browse the Marketplace normally.

Not too certain if any change will be done to prevent this issue, but at least we found the root cause.

Do you have a VPN on by chance? This tends to be a common issue for VPN users

Edit: Didn’t finish reading your message, oops. Guessed it :wink:

This would be nice, but I’m pretty sure the issue is these IPs are being used by heaps of people at once and it’s nearly impossible to implement adequate rate-limiting that’s not IP-based, so they kind of have no choice. Are you using a free VPN by chance? If it’s paid, sometimes you’ll have a dedicated IP that isn’t used by other people, so you might have a chance there. If not, there’s probably nothing you can do other than turn it off.

1 Like

I see, thank you for the information.

My VPN is paid but offers a Dedicated IP for an additional fee. I actually did not know this and I’m glad you told me.

I completely understand as to why I’m getting rate limited on the website, I now wonder why I’m not rate limited on the app because the VPN I’m using is not via a Chrome Extension but rather an app on my pc.


1 Like

Glad I could help.

Hmm. Have you tried browsing the catalog on the app at a time when you’re getting rate limited by the website? It should theoretically show an error, just maybe not in the same form. I’m pretty sure both the website catalog and the in-app catalog call the same APIs (with the same rate limiting, obviously), but I might be wrong.

Yeah I tried it, when I took the images for the post they were all almost at the same time. :person_shrugging: weird

1 Like

Pls do not use a VPN when accessing our website or using our app. We treat traffic from VPNs very differently and thus they are assigned a very low budget before getting throttled. I don’t think you are spamming our servers with a lot of requests in a short window of time, it’s just the threshold is very low to begin with.

1 Like