Max Place Memory Size? / Max Studio Place File Size?

I’ve been wanting solid answers to the questions revolving around studio place file sizes, and what is the max, what can and cannot be published, etc. In my escapades, I’ve been unable to find a concrete answer.

I’m asking if anyone knows how I can maybe fix this issue without destroying my game too much, or perhaps if anyone has a concrete answer on what the max size is. As well as just comments on memory in general.

What brought me to finally make my own post on this:

One of my maps/places has been uploading/publishing to Roblox all fine and good. Till one day, every time I hit publish, after a minute, it fails.

I go to save the file to my PC and check the file size and it’s around 127Mb.
That doesn’t seem very large at all, around 2Gb in Studio Performance Place memory.

But for some reason now all of a sudden it’s unable to upload because of its size, and I know its size because I’ve had this issue before and it seems capped around the 100 area.

I did some deleting and got the file to around 118Mb, and I publish it fine, a little later I go to publish it again and it is failing again.

I’ve gotten it to consistently publish again around a 100Mb place file size.

This seems like quite the low max file size: 123 - 100 Mb

  • 8k by 8k Smooth Terrain ( I know 15k+ starts to not publish)
  • Not a whole lot of physical parts either.

I’m not in the business of making a low poly optimized game but this max file size just recently grasped one of my places for some unknown reason, and its inconsistency and “low cap” makes it even more frustrating; I’m having to delete large amounts of assets in Storage etc just to try and appease the supposed, UNWRITTEN (that I’ve been able to find) place memory cap.

The mentioned place’s performance stats:

The mentioned place’s file size (after some deletion, still doesn’t publish consistently):


In my opinion, I don’t believe I’m rocking with a massive game here. I’ve worked with studio for years, I’m a fairly good scripter, and I like to make an immersive experience. My games don’t take long to load at all and I’m desperate here because I really need every asset I have in my maps.

I’m asking if anyone knows how I can maybe fix this issue without destroying my game too much, or perhaps if anyone has a concrete answer on what the max size is. As well as just comments on memory in general.

And if this is the max file size, please raise it.


Just now, I tried to publish the place, it failed.

I then went to delete all the sounds in server storage, (around 200mb place memory), and publish the place with Success

I then readded all those sounds I deleted, hit publish again, and it also went through to publish successfully.

Weird man. :neutral_face:


I have the same problem only with terrain sometimes it saves sometimes it doesn’t I think it’s my own wifi.

1 Like

I don’t think so.
(chunga chunga)

1 Like

400 MB of Terrain, 300 MB of Sounds, 150 MB of textures, 400MB of physics parts, 150MB of graphics parts.

That is…

Since you need every asset, instead of having all assets sit in the game during runtime, only instance them when you need to. I’m pretty sure not all of those sounds aren’t going to be playing for a client at once. Instead, only instance the sound when you need to, then throw it away with Debris service.

For textures, I would consider using them only on the sides where people see them. Putting textures on all sides, even those that will never be seen will add extra memory and server lag that you can throw away.
The same goes for graphics parts

I would recommend Streaming Enabled, for the physics Parts. If you don’t want that, you can see if you can condense some instances into one with meshes through blender or other CAD software. This is good ESPECIALLY if you have a lot of repetitive parts. Like a bunch of the same tree model, or a bunch of the same flower, etc. This way, the server would only have to render one type of mesh, instead of a bunch of individual parts. Alongside, if any parts you have CanCollide turned off and meshed or unioned, ensure the collision fidelity is a box. Lastly, you should remove the cantouch property from all your parts unless you need it in a script.

For terrain, just like textures, you should remove the terrain people aren’t going to see. If you have a flat map, that’s 500x500, but the depth is 1000, and you have no instance where the client will see the whole underground, remove that depth. Or if a client will never see the inside of a mountain, remove the insides of that terrain.

Your scripting seems fine. No untracked memory and your heap are only 93 for the big game load you have.

To answer your question, I would try to stick to around 1.2GB at an absolute max. Anything higher is where I personally start to see performance issues, and server latency.

File size is in direct relation with memory. So if you lower one, you lower the other.

Hope this helps


I have been running into this ‘one minute’ limit as well. I think with a recent update of studio they have limited the game publish time to one minute. I’m pretty sure before that it was 2 minutes. I really wish they would revert this change, I cannot update a large terrain test map I have been working on.

Having a timed upload limit isn’t really fair to those of us with limited upload bandwidth. My house ISP limits uploads to 5mbit. So with Roblox’s new limit, my game size limit to be able to publish consistently is around 30MB(in file size).

I’ve tried to open a bug report on this but haven’t gotten any response, maybe someone with more pull can open one on this. (please).

I could understand a hard size limit on place file size, but punishing people with slow internet doesn’t seem like a fair way to limit.


So I did a lot of clean up with some instances, sound files, etc. Helped a bit but still had the issue with just lower place memory. However once I made the map a team create, the placememory went from 1.5g to 36mb. And this was similar for all the places in the Universe game, which all now publish consistently and easily whilst having team create on.

Also could you explain heap. :cold_face:


Lua heap is basically any connection you have.

Event connections mainly, but anything along the line of RemoteEvent.OnServer/OnClientEvent, BindableEvent.Event, BindableFunction.On Invoke, RunService.Heartbeat… GUIButton.MouseButton1Click etc.

So, if you want to reduce this, make your connections more simplified. You can do this by minimizing any events that trigger more events. For example, a sprint event

local sprintEvent = game.ReplicatedStorage.SprintEvent
local isSprinting ='BoolValue')

    if isSprinting.Value == false then
    `isSprinting.Value = true
    `isSprinting.Value = false

    if bool then -- Sprint
    else -- Sprint code here

Don’t do that ^. Minimize the number of connections you have so lua heap doesn’t become a problem. Only use connections when necessary.

1 Like

For this, make sure you are testing it while playing it in game. I know sometimes my place memory on the server would be 2.2 GB in studio, but in game, it would only be 1.3 GB or something (server sided).

You seem knowledgeable so could you maybe take a look at my other engine post on Memory which still is affecting me?

I’ve been having the same issue for days with my game as well. Opening the game and just hitting publish (publishing the exact same place that has already been published) shows the “Publish failed” screen as well for some reason.
The place memory size is around 400MB and the file size is 6.2MB. The only thing that would make the game save/publish is deleting everything in ServerStorage, StarterPlayerScripts, Workspace, ReplicatedStorage, etc.
It’s especially weird since there’s games on Roblox that are much bigger than mine, yet are published. I even recall my game file size being more than double of what it is right now and publishing fine.
Game link is Dread: New Map + Gifts Opened! - Roblox.
I’ve tried the solutions above, as well as saving the place as a file and publishing it to other games, but nothing seems to work. Could anyone help me with this issue?


Yeah, you’re right. I have to turn off every other device connected and then only have Studios running to upload my map.


my only consistent solution was making the place a team create.

I’ve turned on Team Create and tried clicking publishing one of my .rbxl files as the place, but it still shows the “Publish failed” screen.

are you sure it’s a team create? I think I had to remove most of server storage and then make it a team create, once it was a team create I was able to add back in all the assets and publish consistently.

Yep. Not being able to use the “Publish place as” feature is a big problem since I use it for publishing updates

Uh do the publish not publish place as if you don’t need a new place

Roblox needs to fix this, they broke it a few weeks ago. Its a timeout on the upload. They are limiting the publish to 60 seconds now(maybe 70). So, if you don’t have a fast internet, good luck uploading large places.

I tried to post a bug report but it seems they are not going to move my post. And I can’t post there.

1 Like