Mesh location data not working

When i insert my mesh from blender roblox gives an option to move the mesh to the location it had in blender. This means that when i insert multiple parts they fit together just like they did in blender. Recently this option has not been working and importing guns into roblox has been a tedious process in which ive had to manually assemble the models. If anyone knows how to fix this please help me! I’ve tried everything and i cant get it to work and no one else seems to be having this problem.

Is your mesh too big or too long? Not sure if this could help but I used to have that problem with my waterfall. I just need to smaller it down for it to work.

No its not too big, its a revolver that’s properly scaled. The mesh imports into the game but it doesn’t go to the right location, instead it just goes wherever the mesh part was.

Hmm that’s strange. Just tested it and it worked fine for me. Did you export it as an obj. or a fbx. ?

I exported it as an obj. 30chars

Did some researches, found a topic that might help you:

1 Like

Thanks i found a solution in there!