Messaging service is down (Retry after -2147483648 seconds.)

Currently, I am getting consistent errors on all of my game servers using MessagingService. The error reads as follows:

"The rate of publish requests exceeds the allowed limit." MessagingService: Please retry after -2147483648 seconds.

-2147483648 seconds is an impossible time and is an int overflow. None of the requests have gone through.

I am well within the allowed publish rate and this error has begun suddenly a few hours ago.



Same thing happening here. Currently unable to even subscribe to the Messaging Service.

MessagingService: Service disconnected.


Same issue happening with our game.

We can subscribe to MessagingService, but are running into the publish limit issue.Doubly frustrating because we use MessagingService to find open servers to group players together!


A game I work on is now completely broken because of this error. Started at roughly the same time, no changes to code has been made.


I had this issue and recently fix it by creating a scheduler for my problems.

I think my issue was mostly related to one of my scripts breaking and spamming the service, but I fixed it by creating a single object/script that handled all the sending of the messages. It could be that one of your scripts has passed one of the limits given by the API and therefore has to calm down. I would personally try to keep messages down to once every 10-30 seconds. Just make sure you stay within 1 kb I guess.

I was having the issue about a month ago and had never experienced the issue before then. A day after the issue occurred it resolved on its own and ive never seen it again, so I do believe this was an API failure rather than me exhausting the rate limit.

Although its always important to be mindful of the limits while creating your systems.

1 Like

About a week ago, the MessagingService completely broke, showing the same error in the image below. This issue was then fixed a few days ago, until users started reporting that the game was completely broken yet again.

This is the second time it has broken in 2 weeks with this same issue, and it makes the game completely unusable. This is a massive flaw that needs fixing asap, as it completely breaks several games, and breaks some functions in other games.

Game: Camp Horizon, Kirkby, Liverpool - Roblox

What should happen: A GUI shows up allowing you to join a server, or create one (lobby system).

If you want a quick fix you have to rename your topic (not on devforum, from where you are sending messages using MessagingService)… otherwise it will fix itself after a long period of time.

This bug has just started affecting my game and has severely impacted it as one of the core features in my game makes use of messaging service to send what servers are active to the game’s hub, it would be nice if this was fixed asap as I now have to hurry to create a temporary solution for this issue.

Link to my game:!/about

Ok this seriously needs to be fixed already, I applied @iiNemo’s quick fix and it worked… for a few hours until it broke again while I was at school and could not do anything to fix it again. This bug seems pretty important to fix and I don’t think it could simply be ignored for so long.

My game relies on MessagingService for matchmaking and this issue has decimated its population. It would be nice if this was at least acknowledged.


Yes some form of acknowledgement of this bug would be nice, My game only just started out a month or two ago and it was hard enough getting a lot of players to notice the game, this bug completely kills my game as I rely on MessagingService to notify the hub that worlds are active, without it players have to rely on sharing world codes with other players (which isn’t exactly ideal) and I am tired of having to make a temporary fix every few hours just so that the game can be playable.

Please, Roblox, say something; this is killing our games and hasn’t been addressed in over a month.

1 Like

This issue has been happening quite randomly for me. At first I thought i surpassed the 1KB data limit, so each request I made was less than ~600 bytes and the problem seemed to go away. Still started to randomly happen soon after though.

Changing topics eliminates this issue but using the same topic causes this weird issue.


Same here, constantly happening, my game has an in-game server browser to see the player names and it has since stopped working completely. I hope ROBLOX says something about this.

Messaging service has always been a bit of a buggy mess, which is a shame since theres so many useful applications for it. But having the service be basically unsuable for over a month now without at least an aknowledgement of its status, doesn’t exactly inspire much confidence in having the service be a core part of your game.


It’s especially bad though because there isn’t really an alternative or workaround, unlike a lot of other bugs. The coder for my game had the idea of opening multiple Messaging Service topics at once and cycling through them when one is detected to have bugged out.

We’re have the exact same problem as described.

This is a major issue for us as we rely on MessageService to list our game servers which users get a selection from whilst being in our lobby game. Changing Topics isn’t a feasible fix as it happens so often it require a server shutdown and change every 10 minutes.

We really need some sort of fix/reply or clarification if this is on our fault. However, I know for a fact that our servers are coming nowhere near the publish requests limit listed within the API.

This is really affecting our playercount so a fast response/fix would really be appreciated.

The same is happening to my game. It DEPENDS on messaging service for global stocks & global killfeed. This really needs to be fixed :frowning:

I can confirm this issue has been plaguing one of my games, Rise of Nations, as it relies on the service for the lobby system.