Microphone On By Default & Cannot Mute

Edit 08/19/2023): Although for myself this does not hold true, some users whose mic appears unmuted really is unmuted. Whether or not the issue is purely visual seems to depend on a per person basis.

Edit (08/10/2023): After further investigation it seems the issue is purely visual. Upon joining, the microphone icon appears unmuted and detects your input, but there is no output returned to other users. Additionally, the issue can be resolved in a server by switching your microphone input, as noted by @checkersoda.

Edit (08/08/2023): The issue is happening quite frequently since the initial incident. In my experience, it has about a 50% chance of occurring.

Edit (08/05/2023): The issue reoccurred in a game that I have developer access to. This time I was able to check the client and server output, but there were no associated errors or warnings. Once again, it exhibited the same behavior with the exception of rejoining being able to fix it.

Description
After joining a game, my mic was on by default, and I was unable to turn it off. I tried both the button above my head and the button in the escape menu, but neither exhibited any functionality. The issue only occurred within a single server on this game, and all other servers functioned correctly. Through testing, I discovered that this is not a visual issue. My microphone UI showed that it was receiving input, and clicks had no impact on its ability to do so. Since I am not a developer of the game that I experienced the issue in, I was only able to check for client-sided errors and warnings, of which there were none. Since this issue consistently occurred within a single server regardless of rejoining, I do not believe it is due to how the game is scripted. Even if it were, developers should have no ability to override such privacy.

Reproduction
Issue is 100% reproducible within the specific server; however, I cannot reproduce the issue elsewhere.

Actual Behavior
Microphone is on by default and cannot be muted.

Expected Behavior
User should have full control over their microphone settings.

22 Likes

Hey there @Bobytoeburrito ! Can you provide me a little more detail of what happened? For example, please tell me what platform you’re using…and maybe a timestamp? What account were you using at the time?

I just checked out a few servers and I am unable to reproduce…

11 Likes

This glitch occurs for me as well across random ROBLOX games at random times and there’s no surefire way to replicate it (at least for me).

I’m on PC and this glitch has been happening since I had access to VC during the start of its beta release. Everything is the same as the OP where the microphone will be on by default and any of the mute buttons will not work. The only way I’m able to properly mute my microphone is by switching input.

7 Likes

I am experiencing the issue at random with this account while using a Windows 10 desktop (11th Gen Intel Core i7 @ 2.50 GHz, 16 GB, NVIDIA GeForce GTX 1660) with a USB mic (Samson G-Track Pro). Since the initial bug report, I have experienced it numerous times across various games. I have updated the post to reflect this. I unfortunately don’t have a timestamps, but I will provide ones for future instances. Is there any other information that would be beneficial?

I was able to successfully reproduce the issue with the first VC game I joined, which occurred at 8:07 AM EST, 08/08.

7 Likes

I have also experienced this issue in all voice-enabled experiences, a workaround is to change the voice input device as that refreshes the voice chat input system.

This issue can be 100% reproduced on my account on my PC (see my most recent bug report for specs) in any voice enabled experience, it started occurring on the 2023-07-20T23:00:00Z for me.

It’s worth noting that this is the same time that I started receiving a bug in where Roblox would not load the window until after the game join loading screen had dissappeared.

7 Likes

I can confirm the duality of that bug wherein the application will not appear until after the loading screen has disappeared. Through further testing, it seems that the bug only occurs when the delaying application launching occurs as well. Unlike Abcreator, I am not experiencing this with 100% reproducibility, but it is very high.

8 Likes

Could you attach a log file from the session where it happened? Thanks in advance!

5 Likes

I have sent you the log file in a DM.

6 Likes

@Bobytoeburrito do you have any update on this? Are you still experiencing this problem?

5 Likes

I still experience this issue, recently it’s happened a lot more in an experience such as Tower of Hell or experiences that utilize TeleportService frequently.

6 Likes

I have not experienced the issue since our last correspondence. I also tried joining Tower of Hell as @checkersoda mentioned above, but I was unable to replicate the issue. It seems to have completely gone away on my end.

4 Likes

Thankfully this issue is visual, so I can’t complain about its severity, but at least it’s alleviated on one person.

I just joined Tower of Hell to see if something had updated on my end, but it seems to still persist.
If it helps, @perunrx, I can send a log file from my session.

3 Likes

I think I got the solution to the issue!

I don’t think it’s Roblox’s fault. It’s Windows!

I was doing some research the other day because for awhile now I’ve experienced the following on the latest Windows 11 Pro 22H2 update. It doesn’t matter what edition of Windows 11 you have, as I also experienced this on Home before upgrading to Pro.

What you’ll experience:

Windows 11 was a huge hurdle for a lot of Developers (not us, but the people making games or engines like Roblox’s, so more so the engineers of this very platform) and it’s been known quite well for being buggy since release, as well as having a few side effects with programs that worked just fine on Windows 10.

I noticed this issue does not occur on Windows 10 devices. I’m not sure about newer Windows 10 updates, as what I’m going to touch on later could have possibly been added to Windows 10 as of late. The operating system still receives security updates, in specific.

When launching a Roblox game you may notice:

  • The app takes a considerable amount of time to show up as an icon in the taskbar, or highlight when pinned. I’ve timed this, and the average is usually about 6-10 seconds for me. I do believe this timing is based on your PC, however. I should also note that it takes a little bit of time after when the icon shows up in the taskbar to open the actual window. There is a high chance you’ll hear audio from the game, but not see the window pop up immediately.

  • Streaming Roblox, or opening any form of recording or streaming software can sometimes occur in this white window flashing at a random sequence.

  • Voice Chat almost always fails to load depending on the complexity of the game you join.

So, what is going on?

Windows 11 introduced many new security changes, one of which is Core Isolation (Memory Integrity), and VMP.

These two changes were to enhance the security on the Windows operating system by allowing windows to check and lock down high security processes with extensive memory checking to ensure malicious programs don’t tamper with your system. This is a massive security benefit, but it has a drawback.

On Microsoft’s post, by the title “Options to Optimize Gaming Performance in Windows 11”, they say…

“VMP provides core virtual machine services for Windows. Memory Integrity helps prevent attackers from injecting their own malicious code and helps ensure that all drivers loaded onto the OS are signed and trustworthy.”

“As part of continued testing and feedback from users, Microsoft has seen that in some scenarios and some configurations of gaming devices there may be a performance impact with Memory Integrity and VMP on.


With this in mind I thought I had to try disabling these features.

I do not recommend disabling these if you care about your security over performance! I should also note that this fix might not work for everyone as it seems to only have an effect on some computer configurations!

How do we disable them?

Microsoft provides the solution to disabling both in the original article I linked, in which I made a step by step here:

Memory Integrity

  1. Searching for “Core Isolation” in Windows search, and opening the first result.

  1. Switching off the toggle for Memory Integrity.

image

This will require a restart, but I do not recommend restarting yet until you disable the other setting below!

VMP (Virtual Machine Platform)

  1. Searching for “Turn windows features on or off” and opening the first result.

  1. Clicking the checkbox next to “Virtual Machine Platform”.

image

When you unchecked the box, hit the “OK” button, and windows will make the changes. After this, restart your PC and try running Roblox again.

What if the settings are turned off, but I still experience the issue?

As Microsoft said, it is particular to certain setups. Your case might be different from what I showed here, but this fix doesn’t only just fix Roblox, but issues with other games. I noticed my computer performance just got overall better, I can actually see the Roblox loading screen now, and my voice chat never fails when joining a game.

Feedback for Roblox

I feel like unmuting a users microphone when setting up the voice chat system when they first join is a huge privacy flaw. The system should default to a muted state when starting up, or switching microphones.

I noticed whenever you go to switch your microphone input from within Roblox, the “Mic On” indicator in the Escape menu displays instead of “Mic Off”. The reason why people might be experiencing this visual bug is the added startup lag from Core Isolation’s Memory Integrity, and VMP being turned on. Then, the app as the script fails to get what it needs with the two warning messages in the console relating to voice chat, it keeps the users microphone unmuted when it connects to the server instead of keeping it muted.

I’m not 100% sure this will solve everyone’s issue, but I certainly solved mine, and a lot of other applications issues.

I really hope this also helps engineers.

5 Likes

Contrary to this, I experienced the issue on Windows 10 and with memory integrity off the entire time. I know this for certain because I have an incompatible driver preventing its use. Along with that, VMP has been off as well. Additionally, you mention the mic defaulting to an on state as a privacy issue, but this is a purely visual issue in my testing. The UI does display that it is detecting your input, but it’s not actually outputting it to everyone else. This is not to negate your experience, however. It’s important to note that those actions were successful in correcting the issue on your device.

4 Likes

Oh okay, yeah then maybe it is purely visual. Maybe Roblox doesn’t send voice chat data. I just could have sworn someone remembered hearing me speak on a game before when I joined a game with it on. I’d have to do more testing to see.

Though, it should be made aware that as you said, this fixed that for me. I don’t get the visual bug anymore, so it’s still very important that the information is displayed to users just in case this happens to fix their issue.

I did state that this issue only fixes for some users on the platform. Newer PC models likely don’t experience as my friend who has a newer system (2022) doesn’t seem to experience the issue.

Different hardware combos could be the issue, just like how with the Studio Refresh update with the DPI thing was causing Explorer related crashes for some users.

If you have any theories as to how this issue occurs, definitely share as I’m interested in trying to find a solution here, or at least make the process easier for engineers & fellow devs with the same issues.

3 Likes

Not visual for me, ended up getting incredibly embarrassed when a user came up to me and started referring to a conversation I was having on the phone while this bug was occurring.

4 Likes

I had a feeling I was not going crazy. This was the exact same thing I experienced when said issue was affecting me. I was talking with my friends on call, screamed because of something and someone was like “who just screamed?”.

I was a little embarrassed but it’s not like I was super close to the Players in question, so it likely didn’t matter too much.

Regardless of if this issue is visual or not, it’s incredibly stress inducing to see the icon light up when we didn’t specifically hit the Mic icon anywhere. Users are also being auto banned by what seems to be some sort of moderation AI (when I reported someone abusing VC they got banned in under 2 minutes). This issue is even bigger when you’re trying so hard to not get banned because you thought your microphone was off, and decided to use a few swear words. When it comes to being older, using words like those are pretty common in casual conversation. Even when not directed as an insult, but rather trying to use the swear word as filler, similar to that of “uh”, and “um”.

3 Likes

Please send me logs in a DM. If you can repro it consistently maybe we could try to investigate it together live?

1 Like

Apologies for being late. I sent 5 log files.

For clarity, I joined Tower of Hell about 5 or 6 times and experienced the bug every time I joined the experience. I tried a multitude of things (muting through the Escape menu, muting through the VC mic bubble, changing mic input, teleporting) just in case it gets caught in the logs.

I also joined other games, like Murder Mystery 2, Natural Disaster Survival, and Royale High, to see if the bug would persist, and it did not. I included two logs from Murder Mystery 2 just in case they have any difference that might help figure this bug out.

2 Likes

You should update this since more information has been discovered.

By this logic, it’s probably because they put task.wait() at the beginning of one of their core scripts when it should be a WaitForChild.


I guess the best workaround is to disable it from privacy settings, in which you are unable to hear other users or unmute. I wonder what happens when you enable the camera in privacy settings. I wonder if it is still possible to disable it.

2 Likes