Minimap Render [RoRenderV3]

Yea I did get an error when I started the server, but I haven’t gotten it since then, I don’t remember what the error was.

1 Like

You have to press inject script after you make any changes to the configuration… Think of the button like a “Update settings” button.

@Stonetr03 Pm me if you see any error messages.

2 Likes

Task Manager is also a great way to see how many cores you have. I saw @Stonetr03 said he googled his cores but google told him the wrong amount.

1 Like

For me the map is really zoomed out and extremely small is there a y axis modifier thats maybe affecting the resolution?
(Had my friend do it for me since he has more CPU cores)

2 Likes

So in the plugin there is an option for PixelPerStud, that is essentially going to be your resolution, if you increase it you will see the box’s Pixel Size X, and Pixel Size Y increase in value. Those two value determine the size of the final image in pixels, the PixelPerStud determine “resolution”.

1 Like

This doesn’t work at all I pressed insert scripts and nothing happens

1 Like

Is it just me or is there some form of bug going on here not letting me render my map? I have a ‘http connect’ error in my output

1 Like

@CorruptDetected90
@Disobeyedcrab04

Please include screenshots of output when reporting problems

1 Like

Awesome :sunny:

5 Likes

Hello, I’ve got this error when trying to render my minimap.
image
Also, the render don’t progress in the windows app.

1 Like

One of the caveats is that it cannot render super large maps.

I would try dividing the render area into 5 pieces.
image

4 Likes

Hello! Is there any way to remove the purple box? I couldn’t render since I’m on a MacBook pro :joy:

2 Likes

game.Workspace.CurrentCamera:ClearAllChildren()

Paste that in the command bar and it should get rid of the purple box… Also you can render on MacOS, I built this program on a MacBook with Mac compatibility in mind.

2 Likes

Sorry, it was just Studio being buggy. HTTP wouldn’t connect. Thanks this sofware is amazing!

1 Like

My bad, I should have specified, I’m on a 2015 model of the MacBook Pro, so roblox studio itself is a no-no. But thanks!

1 Like

When rendering i keep getting this is the output
LINE FAIL : 0
and nothing shows up in the render app.

Oftentimes the first line will fail, if you just wait then the render will reassign line 0 to another client and continue with the render

My rendering STILL isnt working. I have npm and electron installed the right version of the app installed and the games published with HTTPS service on. Why is it still sitting at 0%? there are no errors or prints in console.

1 Like

This worked brilliantly for me, thanks for the resource.

For anyone worried about this, I’ve rendered two incredibly massive maps and it worked perfectly fine - it just took around 4 hours for each render. :wink:

Click here to view one of the maps

1 Like

Hello! I love this plugin and wanted to say great job making it!

Now, I am having an issue with it. I’ve loaded up 4 local players (as my CPU has 4 cores) and I was excited to see the percentage go up, only to find out no image was generating

Does anyone know why this is happening?

Edit: I fixed it! Idk how but I did

1 Like