Mirrored half of blender isn't being imported properly on ROBLOX?

#1

This is my first time when it comes to blender and meshes, however; I’m trying to import a mesh that I made in blender and to make things alot easier, I decided to make one side and simply mirror it for the other.
image

However, when I exported it and tried to put it into ROBLOX, but this happens. The mirrored half is gone.
image

It’s not entirely gone; it’s there, but on the backside. But this time; the other half is missing. (look closely, it kind of gets confusing.)

This is my export OBJ settings, and I used a plane to make the mesh.
image

4 Likes

#2

I discovered this guide a while back, and it has been quite useful to me. Read Part 1, Section 3. Hope I helped :smiley:

4 Likes

#3

In blender under the modifiers tab, did you click apply on the mirror modifier?

As in here:

image

5 Likes

#4

To add onto this:
Blender doesn’t count the mirrored side of a mesh (for example when displaying triangles, vertices etc), it’s just an illusion created for your covenience.
So if you don’t apply the modifier to your mesh, it will still remain an illusion, and will not export.

2 Likes

#5

I don’t really understand, but I’m assuming you’re talking about mirroring.

I didn’t use that whole thing for mirroring, I just simply Shift+D (duplicate) and CTRL+M on X axis with 3D Cursor as Pivot Point. There were no apply or any sort of stuff.

2 Likes

#6

I did however semi-solved the issue by simply increasing the size. (by extruding)

But these weird edges started to happen.

2 Likes

#7

Ah…
Your mirrored faces are probably reverted then (they appear if you look at them “from the inside”.
The screenshot in the OP supports that too, they look kinda dark.
You can select all faces, and hit Ctrl + N to recalculate normals and flip them so they face the right direction.

Edit:
Didn’t see you mentioned it in OP

3 Likes

#9

Front face showed up, back face has half of it missing.
image
image

2 Likes

#10

Enable Backface Culling in Blender (find it on a tab that can be opened with the N key) to see which faces are inverted.
If Ctrl + N doesn’t fix your issue, you will have to flip normals manually.

1 Like

#11

The left side of the model has it’s normals facing towards the opposite direction, you can tell by the darker shading on the model. Faces are one-sided, which is why you can’t see them from both sides. There are two easy ways you can fix this.

First method: Go into edit mode, hit A to select all faces and press Ctrl + N to recalculate the normals. This should ensure that all faces are aimed towards the proper direction. Alternatively, you can press “Recalculate” in the shading tab on the left toolbar to apply the same effect.

The result shuold look something like this.

Second method: Go into edit mode, select only the left faces, press W and pick “Flip Normals”. This will invert the direction of the normals on the faces you have selected.

The result should be the same as the first process.

It can be difficult to know what your model will look like when importing it into studio, as Blender shows both sides of the faces by default. If you want to know what it’ll look like without exporting it first, you can enable “Backface Culling” in the Shading tab on the right toolbar. This removes all the sides of the faces that you won’t be able to see in Studio, and it’s a valuable tool for those who make game assets.

If your mesh has no thickness but you want to be able to see both sides of the model in Studio, you can do this by going into edit mode, selecting all faces, duplicating them by pressing Shift + D and then Right Click, and flipping their normals by pressing W and choosing “Flip Normals”

If both sides look like this you’ve done it successfully.

9 Likes

Parts of a mesh is hiding when I move away from it
#12

That backface culling also really helped me alot. Thank you!

0 Likes

#14

Well, to be honest; I couldn’t accept the answer because it didn’t really solve my whole issue. But yeah, the backface culling was really an awesome tip.

0 Likes

#15

Actually, modifiers export depending on your export settings, there’s a checkbox that includes modifiers upon export.

1 Like