Model thumbnail assets failing to load

In my game Lumber Tycoon 2 I load model thumbnails to use as images for objects in the game. Recently, most of them have suddenly begun to fail to load (no image).

It appears to have begun happening on the 22nd. These previously never failed to load, but presently the affected assets fail 100% of the time.

Here’s an example of one of the models failing to load. The thumbnail is also failing to load on the website:


This should be working now. We were trying to make some improvements and ended up breaking thumbnails for some models.

1 Like

Just tried a new server, some assets are back but most are not. Will it take a bit for the fix to apply everywhere?

some might take a bit. Eventually they should all be re-generated.

1 Like

On what time scale? No change from two days ago, most thumbnails are still failing.

Can you provide a couple of links to models that are failing to thumbnail?

Sure, here’s a couple:

1 Like

We have some cache corruption causing these thumbnails to not get generated. I’m working on figuring out a fix for this. Thank you for your patience.

Can you attempt uploading the same model for which a thumbnail is not getting generated and see if the new model has it’s thumbnail generated?

Yup, I tried uploading a new model and I also tried reuploading the same model to the same ID and these both successfully generated thumbnails.

I believe while we made some changes to how we cache these there was an issue causing cache corruption that resulted in some models being in this weird state. The change was reverted quickly but fixing the items that were already in the weird state is unfortunately more difficult than we thought. I’m working on fixing that but it’s going to take some time. In the meantime re-uploading should allow you to have Models that have valid thumbnails.